Bug 439034 - anaconda (more likely LVM) failed to create PV
anaconda (more likely LVM) failed to create PV
Status: CLOSED DUPLICATE of bug 439633
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-26 12:36 EDT by Clyde E. Kunkel
Modified: 2008-04-21 04:16 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-21 04:16:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda dump file from failed PV create (713.55 KB, text/plain)
2008-03-26 12:36 EDT, Clyde E. Kunkel
no flags Details

  None (edit)
Description Clyde E. Kunkel 2008-03-26 12:36:04 EDT
Description of problem:
ananaconda failed with traceback trying to create PV

Version-Release number of selected component (if applicable):
11.4.0.55

How reproducible:
Didn't try

Steps to Reproduce:
1. boot Fedora 9 beta dvd
2.select custom partitioning
3.select create PV in a free space region of /dev/sda (would be sda15)
  
Actual results:
anaconda failed with traceback

Expected results:
Create PV, continue with partitioning and installation

Additional info:
on retry, did not try to create a pv (tho subsequently after good install cfdisk
and fdisk show the PV while PVSCAN does not), but had to delete fedora 9 alpha
LV and recreate it since partitioner would not let me just format the original.
 Original was ext4, but don't believe that is relevant.
 
The drive was originally used only as the boot drive for a win vista
installation with vista on another drive.  The first linux distro installed was
fedora 8.  Have noticed that there are unexpected empty space areas on the drive
after the F8 install.  These spaces have remained during subsequent test
installs of rawhide x64, F8 x64 and unity.
[root@P5K-EWIFI ~]# cfdisk -Ps /dev/sda
Partition Table for /dev/sda

               First       Last
 # Type       Sector      Sector   Offset    Length   Filesystem Type (ID) Flag
-- ------- ----------- ----------- ------ ----------- -------------------- ----
   Primary           0        2047*     0#       2048*Free Space           None
 1 Primary        2048*    2050047*     0     2048000*HPFS/NTFS (07)       None
   Primary     2050048*    2056319      0        6272*Free Space           None
 2 Primary     2056320     2474009      0      417690 Linux (83)           Boot
 3 Primary     2474010   625137344      0   622663335 W95 Ext'd (LBA) (0F) None
 5 Logical     2474010     6570584     63     4096575 Linux swap / So (82) None
 6 Logical     6570585     6988274     63      417690 Linux (83)           None
 7 Logical     6988275    47954024     63    40965750 Linux LVM (8E)       None
 8 Logical    47954025    48371714     63      417690 Linux (83)           None
 9 Logical    48371715    73272464     63    24900750 Linux (83)           None
10 Logical    73272465    83007854     63     9735390 Linux (83)           None
11 Logical    83007855   103489535*  1681#   20481681*W95 FAT32 (0B)       None
12 Logical   103489536*  103908419   1194#     418884*Linux (83)           None
13 Logical   103908420   104310044     63      401625 Linux (83)           None
14 Logical   104310045   104727734     63      417690 Linux (83)           None
15 Logical   104727735   625137344     63   520409610 Linux LVM (8E)       None
Comment 1 Clyde E. Kunkel 2008-03-26 12:36:04 EDT
Created attachment 299190 [details]
anaconda dump file from failed PV create
Comment 2 Chris Lumens 2008-04-20 16:35:41 EDT
When you see this error message, does /dev/sda15 exist?
Comment 3 Clyde E. Kunkel 2008-04-20 18:38:08 EDT
I simply do not know because after installing a different way and rebooting, the
partition was there, but not marked as to type.

I believe this is an edge case and, if you like, you may close this bz as not
reproducible.  I can't recreate the same conditions without seriously harming
other testing.
  
Comment 4 Chris Lumens 2008-04-21 04:16:43 EDT

*** This bug has been marked as a duplicate of 439633 ***

Note You need to log in before you can comment on or make changes to this bug.