Bug 439060 - PXE install reading from wrong interface (eth0) instead of (eth1)
PXE install reading from wrong interface (eth0) instead of (eth1)
Status: CLOSED DUPLICATE of bug 447813
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-26 14:47 EDT by eric magaoay
Modified: 2008-06-02 10:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-02 10:42:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description eric magaoay 2008-03-26 14:47:33 EDT
Description of problem:
When performing PXE install through the second (2nd) interface (eth1) instead of
(eth0), the install fails because it always probed for DHCP and download
kickstart from the first interface (eth0) regardless of whether the kernel
command line and/or kickstart file specified the 2nd interface(eth1).

Version-Release number of selected component (if applicable):
        anaconda-runtime-11.4.0.58-1.x86_64.rpm
        anaconda-11.4.0.58-1.x86_64.rpm

How reproducible:
        persistent

Steps to Reproduce:
1. Use two interface cards and PXE install through the 2nd interface (eth1)
assigned by the boot program. This is important, install will NOT fail if
installed through the first interface eth0 (the algorithm always search for DHCP
starting from eth0 then eth1... etc.

2. Here is an example for KERNEL COMMAND LINE (located in pxelinux.cfg/default):
        kernel /fed/dev/x86_64/os/isolinux/vmlinuz
        append initrd=/fed/dev/x86_64/os/isolinux/initrd.img ksdevice=eth1 \   
                                        
               ks=http://192.168.3.102/a/ks/f4d3 

   And the KICKSTAET file (/a/ks/f4d3)
        url --url http://192.168.3.102/a/fed/dev/x86_64/os
        network --device eth1 --bootproto dhcp --hostname fiji3

3. 
  
Actual results:
The program stopped and failed when obtaining IP from DHCP through eth0 instead
of eth1

Expected results:
The program would continue if it is able to obtain an IP from DHCP through eth1.

Additional info:
Comment 1 Bug Zapper 2008-05-14 02:53:49 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Andy Lindeberg 2008-06-02 10:42:23 EDT

*** This bug has been marked as a duplicate of 447813 ***

Note You need to log in before you can comment on or make changes to this bug.