Bug 447813 - pxe install fails to query the right dhcp server on 2 interface cards
pxe install fails to query the right dhcp server on 2 interface cards
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
: 439060 (view as bug list)
Depends On: NMinAnaconda
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-21 17:51 EDT by ericm24x7
Modified: 2008-10-07 00:19 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-07 00:19:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ericm24x7 2008-05-21 17:51:14 EDT
Description of problem:
I'm doing a PXE install with a PC that has 2 interfaces (eth0, eth1) connected
to 2 separate network (net0, net2), having its own dhcp server (dhcpd0,dhcpd1).
PXE install often fails when I want to a PXE install through eth1, which should
obtain IP through dhcpd1, but due to algorithm in anaconda it query the IP on
first interface found (eth0), thus getting an IP from dhcpd0 instead of dhcpd1.
The install process then fail to proceed since its assigned IP could not reach
the desired network (net1).

NOTE: due to dynamic re-assignment of NIC card during install, the problem
sometimes goes away after rebooting the install process several times until the
desired interface card is assigned first (eth1 => eth0) thus getting the right
IP from desired dhcp server(dhcpd1 => dhcpd0). So the problem doesn't always
show up. 
  
Desired solution would be to start IP query through dhcp server the interface
where PXE download its pxelinux.0 (often indicated on command line, i.e.
kickstart device > ksdevice=eth1)

Version-Release number of selected component (if applicable):
anaconda.x86_64  11.4.0.82-1 

How reproducible:
Will fail when the desired interface is assigned last (eth1) and query an IP
through the wrong dhcp server (dhcpd0 instead of dhcpd1).

Steps to Reproduce:
1. Prepare PXE install with 2 interface cards with live network and each having
its own separate dhcp server.
2. Try to PXE install through the interface (i.e. eth1) that often assigned last
in order by ananconda install program.
3. below is an example of pxelinux config. (pxelinux.cfg/default)
     label f64r
        kernel /fed/rel/Fedora/x86_64/os/isolinux/vmlinuz
        append initrd=/fed/rel/Fedora/x86_64/os/isolinux/initrd.img
ksdevice=eth1 ks=http://192.168.3.102/a/ks/f4r3

Actual results:
The install process simply stop as soon as it is assigned an IP from the wrong
dhcp server (dhcpd0 instead of dhcpd1)

Expected results:


Additional info:
Comment 1 Andy Lindeberg 2008-06-02 10:42:24 EDT
*** Bug 439060 has been marked as a duplicate of this bug. ***
Comment 2 David Cantrell 2008-10-06 22:43:35 EDT
Is this happening with the latest rawhide builds?
Comment 3 ericm24x7 2008-10-07 00:19:09 EDT
this is working on the latest build I just installed dated 10/6/08.

Note You need to log in before you can comment on or make changes to this bug.