Bug 43911 - anaconda-7.1-14.src.rpm fails to build
Summary: anaconda-7.1-14.src.rpm fails to build
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 1.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-07 21:59 UTC by Need Real Name
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-29 23:14:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-06-07 21:59:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3-5 i686)

Description of problem:
With gettext>0.10.35 intalled:
cat ko.po timeconfig/ko.po | msgfmt -o ko.mo -
<stdin>:5746: invalid multibyte sequence
found 1 fatal error
make[1]: *** [ko.mo] Error 1
make[1]: Leaving directory `/usr/src/redhat/BUILD/anaconda-7.1/po'
make: *** [subdirs] Error 1

With gettext-0.10.35 installed:
cc -g -static -Wall -g -I/usr/include/rpm -I.. -o genhdlist genhdlist.c
hash.c -lrpm -lrpmio \
-lbz2 -lz -lpopt -ldb-3.1 -ldb1
/usr/bin/ld: cannot find -ldb-3.1
collect2: ld returned 1 exit status
make[1]: *** [genhdlist] Error 1
make[1]: Leaving directory `/usr/src/redhat/BUILD/anaconda-7.1/utils'
make: *** [subdirs] Error 1
This error is due to a non-existant libdb-3.1.a since the package
db31-3.1.17-1 does dont build a static version of the library (i.e. no
db31-devel-3.1.17-1)

How reproducible:
Always

Steps to Reproduce:
1.Recompile from source
2.
3.
	

Additional info:

redhat-rawhide-20010524/0604

Comment 1 Brent Fox 2001-06-12 16:08:09 UTC
This works for me...

[root@bfox SPECS]# rpm -ba anaconda.spec 
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.21163
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd /usr/src/redhat/BUILD
+ rm -rf anaconda-7.1
+ /usr/bin/bzip2 -dc /usr/src/redhat/SOURCES/anaconda-7.1.tar.bz2
+ tar -xf -
+ STATUS=0
....
....
....Requires(interp): /bin/sh /bin/sh
Requires(rpmlib): rpmlib(PayloadFilesHavePrefix) <= 4.0-1
Requires(post): /bin/sh
Requires(preun): /bin/sh
Requires: rpm-python ld-linux.so.2 libc.so.6 libart_lgpl.so.2 libaudiofile.so.0 
libbz2.so.1 libcom_err.so.2 libdb.so.2 libdl.so.2 libesd.so.0 libext2fs.so.2 lib
gdk-1.2.so.0 libgdk_imlib.so.1 libglib-1.2.so.0 libgmodule-1.2.so.0 libgnome.so.
32 libgnomesupport.so.0 libgnomeui.so.32 libgtk-1.2.so.0 libICE.so.6 libm.so.6 l
ibpopt.so.0 libresolv.so.2 libSM.so.6 libX11.so.6 libXext.so.6 libXi.so.6 libz.s
o.1 /bin/sh /usr/bin/python libc.so.6(GLIBC_2.0) libc.so.6(GLIBC_2.1) libc.so.6(
GLIBC_2.1.3) libc.so.6(GLIBC_2.2) libm.so.6(GLIBC_2.0) libresolv.so.2(GLIBC_2.0)
 libresolv.so.2(GLIBC_2.2)
Obsoletes: anaconda-reconfig
Processing files: anaconda-runtime-7.1-14
PreReq: rpmlib(PayloadFilesHavePrefix) <= 4.0-1
Requires(rpmlib): rpmlib(PayloadFilesHavePrefix) <= 4.0-1
Requires: anaconda = 7.1-14
Wrote: /usr/src/redhat/SRPMS/anaconda-7.1-14.src.rpm
Wrote: /usr/src/redhat/RPMS/i386/anaconda-7.1-14.i386.rpm
Wrote: /usr/src/redhat/RPMS/i386/anaconda-runtime-7.1-14.i386.rpm
Executing(%clean): /bin/sh -e /var/tmp/rpm-tmp.90731
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd anaconda-7.1
+ rm -rf /var/tmp/anaconda-7.1
+ exit 0



Comment 2 Need Real Name 2001-06-14 22:05:44 UTC
Are you really building from RawHide-20010604, or do you refer to RHL-7.1?

In my case installed packages are:
gettext-0.10.38-1, libtool-1.4-3, automake-1.4p2-1, autoconf-2.13-10

Is this bug tracking system only for releases of RHL SW, not RawHide? Are you
taking bug for RawHide reports seriously? If, not this is just a waste of time.
Please enlighten me.

Comment 3 Brent Fox 2001-06-29 23:14:16 UTC
We do pay attention to Rawhide bugs, but I think it's only fair to give priority
to bugs filed against the most recent official releases.  

I did an install of an internal build yesterday and then rebuilt anaconda with
it with no problems except that some packages required to build anaconda were
not in the spec file.  Those packages have since been added to the spec file,
and things are fine since then.  I guess whatever problem you were seeing in the
Rawhide build have disappeared.  For what it's worth, though, the initial
rebuild I did two weeks ago was pulled from Rawhide.  I don't know if you have
older packages (or newer ones that have problems), but the rebuild worked for me.


Note You need to log in before you can comment on or make changes to this bug.