Bug 439178 - Namazu rpm dependency problem
Namazu rpm dependency problem
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: namazu (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Akira TAGOH
Fedora Extras Quality Assurance
: Reopened
: 441061 (view as bug list)
Depends On:
Blocks: 439373
  Show dependency treegraph
 
Reported: 2008-03-27 09:47 EDT by Raina Otoni
Modified: 2008-04-09 01:20 EDT (History)
3 users (show)

See Also:
Fixed In Version: 2.0.18-3.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-09 01:20:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raina Otoni 2008-03-27 09:47:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ja; rv:1.8.1.13) Gecko/20080325 Fedora/2.0.0.13-1.fc8 Firefox/2.0.0.13

Description of problem:
When I update by "yum update", display an error message.

[root@houyhnhnms ~]# yum install namazu
Loading "fastestmirror" plugin
Loading mirror speeds from cached hostfile
 * livna: ftp-stud.fht-esslingen.de
 * fedora: ftp.dti.ad.jp
 * updates: ftp.dti.ad.jp
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package namazu.i386 0:2.0.18-1.fc8 set to be updated
--> Processing Dependency: perl(time.pl) for package: namazu
--> Processing Dependency: perl-File-MMagic >= 1.12 for package: namazu
--> Processing Dependency: perl-Text-Kakasi >= 1.00 for package: namazu
--> Processing Dependency: perl(conf.pl) for package: namazu
--> Processing Dependency: perl(util.pl) for package: namazu
--> Processing Dependency: perl(File::MMagic) for package: namazu
--> Processing Dependency: perl(var.pl) for package: namazu
--> Processing Dependency: perl(nmzidx.pl) for package: namazu
--> Processing Dependency: perl(document.pl) for package: namazu
--> Processing Dependency: kakasi >= 2.3.0 for package: namazu
--> Running transaction check
---> Package perl-Text-Kakasi.i386 0:2.04-6.fc8 set to be updated
---> Package namazu.i386 0:2.0.18-1.fc8 set to be updated
--> Processing Dependency: perl(time.pl) for package: namazu
--> Processing Dependency: perl(conf.pl) for package: namazu
--> Processing Dependency: perl(util.pl) for package: namazu
--> Processing Dependency: perl(var.pl) for package: namazu
--> Processing Dependency: perl(nmzidx.pl) for package: namazu
--> Processing Dependency: perl(document.pl) for package: namazu
---> Package perl-File-MMagic.noarch 0:1.27-3.fc8 set to be updated
---> Package kakasi.i386 0:2.3.4-24.fc8 set to be updated
--> Finished Dependency Resolution
Error: Missing Dependency: perl(time.pl) is needed by package namazu
Error: Missing Dependency: perl(util.pl) is needed by package namazu
Error: Missing Dependency: perl(document.pl) is needed by package namazu
Error: Missing Dependency: perl(nmzidx.pl) is needed by package namazu
Error: Missing Dependency: perl(var.pl) is needed by package namazu
Error: Missing Dependency: perl(conf.pl) is needed by package namazu


Version-Release number of selected component (if applicable):
namazu.i386 0:2.0.18-1.fc8

How reproducible:
Always


Steps to Reproduce:
1. type "yum update"


Actual Results:
can't update namazu

Expected Results:
successfully resolve the dependency, then update namazu

Additional info:
Comment 1 Raina Otoni 2008-03-27 09:50:01 EDT
Sorry, I pasted wrong message.
following message is correct.

[root@www ~]# yum update
Loading "downloadonly" plugin
Loading "fastestmirror" plugin
Loading mirror speeds from cached hostfile
 * fedora: ftp.kddilabs.jp
 * updates: ftp.kddilabs.jp
Excluding Packages in global exclude list
Finished
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package namazu.i386 0:2.0.18-1.fc8 set to be updated
--> Processing Dependency: perl(time.pl) for package: namazu
--> Processing Dependency: perl(conf.pl) for package: namazu
--> Processing Dependency: perl(util.pl) for package: namazu
--> Processing Dependency: perl(var.pl) for package: namazu
--> Processing Dependency: perl(nmzidx.pl) for package: namazu
--> Processing Dependency: perl(document.pl) for package: namazu
---> Package namazu-cgi.i386 0:2.0.18-1.fc8 set to be updated
--> Finished Dependency Resolution
Error: Missing Dependency: perl(time.pl) is needed by package namazu
Error: Missing Dependency: perl(util.pl) is needed by package namazu
Error: Missing Dependency: perl(document.pl) is needed by package namazu
Error: Missing Dependency: perl(nmzidx.pl) is needed by package namazu
Error: Missing Dependency: perl(var.pl) is needed by package namazu
Error: Missing Dependency: perl(conf.pl) is needed by package namazu
Comment 2 Jeroen van Meeuwen 2008-03-27 19:26:50 EDT
Seconded, I'm experiencing this too.
Comment 3 Akira TAGOH 2008-03-28 07:43:08 EDT
Fixed in 2.0.18-2.fc8.
Comment 4 Fedora Update System 2008-03-28 07:46:03 EDT
namazu-2.0.18-2.fc8 has been submitted as an update for Fedora 8
Comment 5 Fedora Update System 2008-04-01 17:33:20 EDT
namazu-2.0.18-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 jonathan baron 2008-04-03 05:34:37 EDT
Problems still persist:
--> Running transaction check
---> Package namazu.i386 0:2.0.18-2.fc8 set to be updated
--> Processing Dependency: perl(filter.pl) for package: namazu
--> Processing Dependency: perl(entity) for package: namazu
--> Processing Dependency: perl(alloca) for package: namazu
--> Processing Dependency: perl(ooo.pl) for package: namazu
--> Processing Dependency: perl(mailnews.pl) for package: namazu
--> Processing Dependency: perl(zip.pl) for package: namazu
--> Processing Dependency: perl(codeconv.pl) for package: namazu
--> Processing Dependency: perl(html.pl) for package: namazu
--> Processing Dependency: perl(gfilter.pl) for package: namazu
--> Processing Dependency: perl(gettext.pl) for package: namazu
--> Processing Dependency: perl(dist-hook) for package: namazu
Comment 7 Akira TAGOH 2008-04-03 09:10:31 EDT
sigh. perl.req may be broken then. the old package used to invoke find-requires.
Comment 8 Fedora Update System 2008-04-03 09:58:09 EDT
namazu-2.0.18-3.fc8 has been submitted as an update for Fedora 8
Comment 10 Akira TAGOH 2008-04-06 22:29:43 EDT
*** Bug 441061 has been marked as a duplicate of this bug. ***
Comment 11 Fedora Update System 2008-04-09 01:20:35 EDT
namazu-2.0.18-3.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.