Bug 439218 - mod_proxy_balancer: configured session identifier is case-sensitive
mod_proxy_balancer: configured session identifier is case-sensitive
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: httpd (Show other bugs)
5.1
All Linux
medium Severity medium
: rc
: ---
Assigned To: Joe Orton
:
: 450058 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-27 11:49 EDT by Martin Poole
Modified: 2011-02-07 08:55 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:07:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Apache Bugzilla 41897 None None None Never

  None (edit)
Description Martin Poole 2008-03-27 11:49:23 EDT
Description of problem:

StickySession variables passed to Tomcat5 via URL are differently cased than the
Cookie sent back; mod_proxy_balancer gets confused.

This bug is tracked upstream as
 
  https://issues.apache.org/bugzilla/show_bug.cgi?id=41897

although the proposed patch has not yet been accepted.
Comment 3 Joe Orton 2008-05-13 07:35:00 EDT
This has now been committed for trunk and backported to 2.2.x, here:

  http://svn.apache.org/viewvc?view=rev&rev=557993
Comment 5 RHEL Product and Program Management 2008-06-02 16:11:56 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 12 errata-xmlrpc 2009-01-20 16:07:30 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0185.html
Comment 15 Joe Orton 2011-02-07 08:55:20 EST
*** Bug 450058 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.