Bug 450058 - mod_proxy ballancemember stickyness
mod_proxy ballancemember stickyness
Status: CLOSED DUPLICATE of bug 439218
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: httpd (Show other bugs)
5.4
All Linux
low Severity low
: rc
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-04 20:45 EDT by Lawrence Walton
Modified: 2011-02-07 08:55 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-07 08:55:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lawrence Walton 2008-06-04 20:45:50 EDT
Description of problem:
balancermember stickiness does not apear to work in httpd

Version-Release number of selected component (if applicable):
current 
2.2.3-11
How reproducible:
ProxyPass /stickiness-test balancer://stickiness-test
stickysession=JSESSIONID|jsessionid nofailover=On lbmethod=bytraffic
ProxyPassReverse /stickiness-test balancer://stickiness-test
<Proxy balancer://stickiness-test>
BalancerMember ajp://games-dev15.ra.prognet.com:8009/stickiness-test
route=route15 smax=5 max=10 timeout=60
BalancerMember ajp://games-dev16.ra.prognet.com:8009/stickiness-test
route=route16 smax=5 max=10 timeout=60
</Proxy> 


Steps to Reproduce:
1. use config from above.

Actual results:
None sticky sessions

Expected results:
sticky sessions

Additional info:

Upon request...
Comment 1 Joe Orton 2008-06-05 06:50:47 EDT
Thanks for the report.  The "stickysession=FOO|foo" feature isn't present in
2.2.3 though this is proposed for inclusion in future RHEL 5 updates of httpd
(see bug 439218).  If your backend allows it, stickysession=FOO should work.
Comment 2 Joe Orton 2011-02-07 08:55:19 EST

*** This bug has been marked as a duplicate of bug 439218 ***

Note You need to log in before you can comment on or make changes to this bug.