Bug 439708 - missing error check at "Mounting root filesystem."
missing error check at "Mounting root filesystem."
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-30 17:15 EDT by John Reiser
Modified: 2009-05-05 17:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-05 17:51:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2008-03-30 17:15:53 EDT
Description of problem:  During boot, there is no specific error message for not
finding the root filesystem if specified by "root=LABEL=..." or
"root=UUID=....".  The messages which do appear are confusing.


Version-Release number of selected component (if applicable):
mkinitrd-6.0.40-1.fc9.x86_64


How reproducible: always


Steps to Reproduce:
1. Take a good GRUB stanza, and modify the "root=LABEL=..." or "root=UUID=..."
to name a non-existent filesystem [such as: add "xxx" onto the end of the LABEL,
or increment the last digit of the UUID.]
2. boot
3.
  
Actual results:
Trying to resume from <previous_swap_device>
Creating root device.
Mounting root filesystem.
mount: could not find filesystem '/dev/root'
Setting up other filesystems.
Setting up new root fs
setuproot: moving /dev failed: No such file or directory
no fstab.sys, using internal defaults
setuproot: error mounting /proc: No such file or directory
setuproot: error mounting /sys: No such file or directory
Mount failed for selinuxfs on /selinux: No such file or directory
Switching to new root and running init.
unmounting old /dev
unmounting old /proc
unmounting old /sys
switchroot: mount failed: No such file or directory
Booting has failed.


Expected results:  Explicit check and explicit message for failure, such as:
Trying to resume from <previous_swap_device>
Creating root device.
Mounting root filesystem.
Mount "root=LABEL=<actual_label>" failed: No such file or directory.
Booting has failed.

Additional info:  See contents of /init from initrd.img at bug #439695.
Comment 1 Bug Zapper 2008-05-14 04:27:05 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Jeremy Katz 2009-05-05 17:51:27 EDT
This is a little crufty to fix in current mkinitrd and the next generation initramfs tool (dracut) already handles it a lot better.  Since we're intending to try to move to that for F12, not going to fix this up for the legacy mkinitrd (it's been like this for years and years... six more months isn't going to hurt much)

Note You need to log in before you can comment on or make changes to this bug.