Bug 439718 - (TBe93ef273) TBe93ef273 Conf.py:998:__setitem__:TypeError: coercing to Unicode: need string or buffer, NoneType found
TBe93ef273 Conf.py:998:__setitem__:TypeError: coercing to Unicode: need strin...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
: 440222 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-30 18:41 EDT by Andrew Farris
Modified: 2008-04-02 09:18 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-31 08:43:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Farris 2008-03-30 18:41:26 EDT
Description of problem:
Saving settings changes in system-config-network fails with unicode error.

Summary: TBe93ef273 Conf.py:998:__setitem__:TypeError: coercing to Unicode: need
string or buffer, NoneType found

Version-Release number of selected component (if applicable):
system-config-network-1.5.3-1.fc9.noarch

How reproducible:
every time

Steps to Reproduce:
1. edit eth0 configuration, change dhcp -> static, set NM managed
2. click save

Actual results:
traceback, settings not saved

Expected results:
saved settings changes

Additional info:
Component: system-config-network
Version: 1.5.3
Summary: TBe93ef273 Conf.py:998:__setitem__:TypeError: coercing to Unicode: need
string or buffer, NoneType found

Traceback (most recent call last):
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line
831, in on_applyButton_clicked
    self.save()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line
392, in save
    self.saveHardware()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line
420, in saveHardware
    hardwarelist.save()
  File "/usr/share/system-config-network/netconfpkg/NCHardwareList.py", line
700, in save
    hw.save()
  File "/usr/share/system-config-network/netconfpkg/plugins/NCHWEthernet.py",
line 44, in save
    modules[self.Name] = dic
  File "/usr/share/system-config-network/netconfpkg/conf/Conf.py", line 998, in
__setitem__
    replace = key + ' ' + varname + ' ' + endofline
TypeError: coercing to Unicode: need string or buffer, NoneType found

Local variables in innermost frame:
findexp: ^[	 ]*alias[	 ]+eth1[	 ]+
missing: 1
varname: eth1
self: <netconfpkg.NCHardwareList.MyConfModules instance at 0x9ca6e4c>
value: {'alias': None}
place: 0
key: alias
endofline: None
Comment 1 Harald Hoyer 2008-03-31 08:43:56 EDT
system-config-network-1.5.4
Comment 2 Harald Hoyer 2008-03-31 11:10:27 EDT
real fix in system-config-network-1.5.5
Comment 4 Harald Hoyer 2008-04-02 08:47:17 EDT
*** Bug 440222 has been marked as a duplicate of this bug. ***
Comment 5 Dean Mander 2008-04-02 09:18:23 EDT
works for me. Thanks.

Note You need to log in before you can comment on or make changes to this bug.