Bug 440222 - crash during "save" : UNICODE problem
crash during "save" : UNICODE problem
Status: CLOSED DUPLICATE of bug 439718
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-02 08:31 EDT by Dean Mander
Modified: 2008-04-02 08:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-02 08:47:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dean Mander 2008-04-02 08:31:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9pre) Gecko/2008032721 Fedora/3.0-0.50.cvs20080327.fc9 Minefield/3.0pre

Description of problem:
see errorlog in "detailed information" window


Version-Release number of selected component (if applicable):
system-config-network-1.5.3

How reproducible:
Always


Steps to Reproduce:
1.update configuration on wired interface from static to DHCP.
2.File->Save.
3.Then it crashes

Actual Results:


Expected Results:


Additional info:
Component: system-config-network
Version: 1.5.3
Summary: TBe93ef273 Conf.py:998:__setitem__:TypeError: coercing to Unicode: need string or buffer, NoneType found

Traceback (most recent call last):
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line 831, in on_applyButton_clicked
    self.save()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line 392, in save
    self.saveHardware()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line 420, in saveHardware
    hardwarelist.save()
  File "/usr/share/system-config-network/netconfpkg/NCHardwareList.py", line 700, in save
    hw.save()
  File "/usr/share/system-config-network/netconfpkg/plugins/NCHWEthernet.py", line 44, in save
    modules[self.Name] = dic
  File "/usr/share/system-config-network/netconfpkg/conf/Conf.py", line 998, in __setitem__
    replace = key + ' ' + varname + ' ' + endofline
TypeError: coercing to Unicode: need string or buffer, NoneType found

Local variables in innermost frame:
findexp: ^[      ]*alias[        ]+eth1[         ]+
missing: 1
varname: eth1
self: <netconfpkg.NCHardwareList.MyConfModules instance at 0x8b260ec>
value: {'alias': None, 'options': {}, 'install': [], 'remove': []}
place: 0
key: alias
endofline: None
Comment 1 Harald Hoyer 2008-04-02 08:47:16 EDT
$ rpm -q system-config-network
system-config-network-1.5.5-1.fc9.noarch

update and retry

*** This bug has been marked as a duplicate of 439718 ***

Note You need to log in before you can comment on or make changes to this bug.