Bug 439720 - tzdata upgrade should restart crond and atd
tzdata upgrade should restart crond and atd
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cronie (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
: 439719 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-30 18:47 EDT by JW
Modified: 2008-06-26 02:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-31 11:18:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description JW 2008-03-30 18:47:16 EDT
Description of problem:
tzdata rpm should restart crond when upgraded otherwise crond will continue as
though nothing has changed

Version-Release number of selected component (if applicable):
tzdata-2007h-1

How reproducible:
Always

Steps to Reproduce:
1. upgrade tzdata rpm
  
Actual results:
crond not restarted
atd not restarted

Expected results:
crond needs to be restarted to pick up the changes
atd probably needs to be restarted also

Additional info:
Comment 1 Petr Machata 2008-03-31 07:00:28 EDT
If cron wishes to be restarted after the tzdata update, is should do so itself,
via an rpm trigger.  This is not going to happen in tzdata, the package is too
low-level for that.

Moreover I think restart of the service is too coarse tool, and might be very
disrupting when run in server environment.  But if the cron daemon recognized
some re-schedule signal (or if it does), the trigger could just send that signal
to the daemon, that would be just as good.

Anyway, reassigning to cronie, our NG vixie-cron replacement!
Comment 2 Marcela Mašláňová 2008-03-31 10:50:22 EDT
*** Bug 439719 has been marked as a duplicate of this bug. ***
Comment 3 Marcela Mašláňová 2008-03-31 11:18:57 EDT
I'll add trigger into cronie.
Comment 4 Subhendu Ghosh 2008-06-26 02:33:30 EDT
any update on the trigger?

Note You need to log in before you can comment on or make changes to this bug.