Bug 439832 - Timezone + Worldmap
Timezone + Worldmap
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
: 441423 (view as bug list)
Depends On:
Blocks: F9PR
  Show dependency treegraph
 
Reported: 2008-03-31 12:46 EDT by Jóhann B. Guðmundsson
Modified: 2008-04-11 10:40 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-11 09:53:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jóhann B. Guðmundsson 2008-03-31 12:46:52 EDT
Description of problem:

When selecting city in "timezone" selection, world map
"zooms in/centers" on the south atlantic ocean instead of
the city ( reykjavik ) being chosen.


Best regards
                 Johann B. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:

Reykjavik ( or what the user has chosen )
becomes the center of the world map..

Additional info:
Comment 1 Jóhann B. Guðmundsson 2008-03-31 12:49:57 EDT
/ignore Best regards Johann B. 
( copy and pasted my previously posted findings to the test-list )

:)
Comment 2 Jóhann B. Guðmundsson 2008-03-31 13:36:14 EDT
Oh yea I forgot to mention I was using the Rawhide 20080328 Snapshot i386 DVD
and Rawhide 20080327 Snapshot i686 Live..
Comment 3 Andrew Farris 2008-04-01 06:06:07 EDT
I confirm this happens for me on the snapshot live (both i686 and x86_64) and
also did not happen during install from Beta i686 DVD or Beta x86_64 CDs, when
selecting several cities (none worked correctly).
Comment 4 Nils Philippsen 2008-04-01 12:17:51 EDT
Hmm, I'm interested in which version of s-c-date wound up in anaconda -- I've
got system-config-date-1.9.26-1.fc9 here and everything works smoothly.
Comment 5 Jeremy Katz 2008-04-01 13:39:58 EDT
Whichever version was in the tree is what anaconda would have pulled in.  Which
looks like it would have been 1.9.26
Comment 6 John Poelstra 2008-04-02 15:05:02 EDT
still broken today as verified during install of i386 2008-04-02 rawhide
Comment 7 Jeremy Katz 2008-04-02 23:09:00 EDT
Reproduced as well.  But I can't get it to happen in system-config-date either.
 Zooming before the autozoom was working fine, though
Comment 8 Jóhann B. Guðmundsson 2008-04-05 08:57:01 EDT
Still not working in rawhide 04.04 live iso..
Comment 9 Andrew Farris 2008-04-05 21:24:57 EDT
I also reproduced it with both x86 and x64 20080404 snapshot live (gnome) isos.
Comment 10 Andrew Farris 2008-04-05 21:27:50 EDT
The versions on those images are:
anaconda-11.4.0.65-1
system-config-date-1.9.28-1

As Jeremy said the bug shows up in anaconda, but not in that s-c-d while running
the live cd.
Comment 11 Jeremy Katz 2008-04-07 23:42:30 EDT
*** Bug 441423 has been marked as a duplicate of this bug. ***
Comment 12 Nils Philippsen 2008-04-08 05:21:19 EDT
I've just attempted an installation in a virtual guest and could reproduce the
problem (it didn't recenter the map at all instead of moving somewhere random,
but I digress).

My guess is that anaconda doesn't use the "normal" treeview included with the
timezone_map_gui widget but its own dropdown option menu and that this doesn't
send the needed change events to the map or something like that. I'll change the
component to anaconda as I'm not familiar with the modifications that were done
in that regard.
Comment 13 Chris Lumens 2008-04-08 08:59:38 EDT
Nils - you are correct.  I've updated the timezone code in anaconda to be more
in line with what system-config-date is doing.  Sometime after F-9, we should
revisit this whole page and make sure we're tracking s-c-d as closely as possible.
Comment 14 Nils Philippsen 2008-04-08 09:32:23 EDT
(In reply to comment #13)
> Sometime after F-9, we should revisit this whole page and make sure we're
> tracking s-c-d as closely as possible.

Yes. For the future, we could perhaps target for a search-combo-box thing which
would augment the treeview in the standalone-tool but wouldn't be necessary to
have in Anaconda?
Comment 15 Jeremy Katz 2008-04-11 09:53:01 EDT
Verified that this is fixed
Comment 16 Jóhann B. Guðmundsson 2008-04-11 10:40:41 EDT
Great work :) ...

Note You need to log in before you can comment on or make changes to this bug.