Bug 439861 - Loader crashes if the lang option is given in grub
Loader crashes if the lang option is given in grub
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 442929 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-31 15:47 EDT by Ville-Pekka Vainio
Modified: 2008-04-17 17:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-17 17:35:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville-Pekka Vainio 2008-03-31 15:47:45 EDT
Description of problem:
The loader crashes with SIGABRT if the lang option is given in grub. I've taken
some screenshots of the situation:

1. http://vpv.fedorapeople.org/misc/grub-options.png - the lang option I've given
2. http://vpv.fedorapeople.org/misc/loader-crash1.png - first part of the backtrace
3. http://vpv.fedorapeople.org/misc/loader-crash2.png - second part of the backtrace

Version-Release number of selected component (if applicable):
Anaconda 11.4.0.61 used in Rawhide-20080328-Snapshot-i386-DVD

How reproducible:
Always when the option is given

Steps to Reproduce:
1. Give Anaconda the lang option in grub, for example lang=fi_FI
2. Continue booting
  
Actual results:
Loader crashes with the messages seen in files loader-crash1.png and loader2.png

Expected results:
Loader won't crash and the installation will begin using the Finnish language
(or whatever language the user has given as the lang option, if available).
Comment 1 Jeremy Katz 2008-03-31 19:11:00 EDT
The segfault looks like it's in newt
Comment 2 Miroslav Lichvar 2008-04-01 14:54:55 EDT
The asprintf call is in anaconda code. Either turn off the fortifications or
avoid using %n in gettext strings.
Comment 3 Jeremy Katz 2008-04-01 16:25:26 EDT
Err, whoops.  Sorry Miroslav.  Was trying to get through bugs too quickly
apparently.

Fixed in git
Comment 4 Jeremy Katz 2008-04-17 15:57:41 EDT
*** Bug 442929 has been marked as a duplicate of this bug. ***
Comment 5 Milan Kerslager 2008-04-17 17:20:22 EDT
The bug is fixed in the recent Rawhide, so may be closed.

Note You need to log in before you can comment on or make changes to this bug.