Bug 439878 - .hidden menu entry in gnome after installation of kde applications
Summary: .hidden menu entry in gnome after installation of kde applications
Status: CLOSED DUPLICATE of bug 321771
Alias: None
Product: Fedora
Classification: Fedora
Component: kde-filesystem (Show other bugs)
(Show other bugs)
Version: 8
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-03-31 20:47 UTC by Henrik Nordstrom
Modified: 2008-03-31 21:26 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-31 21:26:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Henrik Nordstrom 2008-03-31 20:47:44 UTC
Description of problem:

After installation of a number of the koffice suite I now have a .hidden submenu
in the gnome Programs menu, with Kalarmd and a number of Krita entries.

Version-Release number of selected component (if applicable):

$ find /usr/share/applnk/.hidden | xargs rpm -q -f  | sort -u
kde-filesystem-4-8.fc8
kdepim-3.5.9-6.fc8
koffice-krita-1.6.3-13.fc8

How reproducible:

Always.

Steps to Reproduce:
1. Install koffice using pirut
2. Login using Gnome
3. Take a look in the Programs menu.
  
Actual results:

A .hidden submenu folder shown with some odd looking entries

Expected results:

No .hidden submenu folder

Additional info:

$ find /usr/share/applnk/.hidden
/usr/share/applnk/.hidden
/usr/share/applnk/.hidden/krita_tiff.desktop
/usr/share/applnk/.hidden/krita_raw.desktop
/usr/share/applnk/.hidden/krita_openexr.desktop
/usr/share/applnk/.hidden/krita_jpeg.desktop
/usr/share/applnk/.hidden/krita_magick.desktop
/usr/share/applnk/.hidden/kalarmd.desktop
/usr/share/applnk/.hidden/krita_pdf.desktop
/usr/share/applnk/.hidden/krita_png.desktop

.hidden is owned by kde-filesystem
krita*.desktop by koffice-krita
kalarmd.desktop bu kdepim

Not sure if this is a bug in those packages, or if Gnome is supposed to simply
not show these in the menu..

Comment 1 Rex Dieter 2008-03-31 21:26:14 UTC
Fixed in kde-filesystem-4-9, coming soon as an update.

Comment 2 Rex Dieter 2008-03-31 21:26:36 UTC

*** This bug has been marked as a duplicate of 321771 ***


Note You need to log in before you can comment on or make changes to this bug.