Bug 321771 - kdepim: adds ".hidden" menu to gnome menus
kdepim: adds ".hidden" menu to gnome menus
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kde-filesystem (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
: 245190 439878 (view as bug list)
Depends On: 245190
Blocks: F9Target
  Show dependency treegraph
 
Reported: 2007-10-07 00:20 EDT by Gordon Messmer
Modified: 2008-03-31 17:26 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-28 07:03:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gordon Messmer 2007-10-07 00:20:44 EDT
Description of problem:
The kdepim package contains this file:
/usr/share/applnk/.hidden/kalarmd.desktop

All of the other applnk files in that package contain the line "Hidden=true",
but this one does not.  As a result, the Gnome "Applications" menu contains a
".hidden" item, in which the kalarmd item is kept.

This file should also contain "Hidden=true" so that it is consistent with the
rest of the package, and doesn't clutter the Gnome menus.

Version-Release number of selected component (if applicable):
kdepim-3.5.7-9.svn20070926.ent.fc8
Comment 1 Rex Dieter 2007-10-08 07:46:14 EDT
gnome-menus bug not supporting legacy .hidden/*.desktop files,
see bug #245190
Comment 2 Michel Alexandre Salim 2008-01-27 15:02:01 EST
As a short-term fix, could we just fix kdepim? This is getting rather annoying.
Comment 3 Rex Dieter 2008-01-27 15:10:08 EST
We've got much bigger fish to fry, I'm afraid, so this is low-priority for us
(esp since gnome is the only DE having this issue).

Consider too that changing .desktop files (esp legacy ones) is a non-trivial
thing to do, and sometimes causes unforeseen side-effects (we've had breakage
occur before), so I'm not prepared to do that before having ample time to
properly QA the change.
Comment 4 Ngo Than 2008-03-28 07:03:06 EDT
it's fixed in kde-filesystem-4.9.fc9. thanks for your report
Comment 5 Rex Dieter 2008-03-28 08:14:58 EDT
*** Bug 245190 has been marked as a duplicate of this bug. ***
Comment 6 Rex Dieter 2008-03-31 17:26:37 EDT
*** Bug 439878 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.