Bug 439902 - system-config-firewall crashes when locale does not use UTF-8 encoding
system-config-firewall crashes when locale does not use UTF-8 encoding
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: system-config-firewall (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-31 18:29 EDT by Andrew Zabolotny
Modified: 2009-01-09 01:17 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 01:17:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The diff against 1.0.12 sources (43.49 KB, patch)
2008-03-31 18:29 EDT, Andrew Zabolotny
no flags Details | Diff

  None (edit)
Description Andrew Zabolotny 2008-03-31 18:29:07 EDT
Description of problem:

When I run system-config-firewall in my locale (which is ru_RU.CP1251) it
silently crashes. It also crashes for any other encoding except UTF-8.

Version-Release number of selected component (if applicable):

1.0.12-4

How reproducible:

Always

Steps to Reproduce:
LANG=ru_RU.KOI8-R system-config-firewall
  
Actual results:
It crashes

Expected results:
Should run :)

Additional info:
Here's a patch that fixes this. It also includes a major update of the Russian
translation which seems to be unmaintained for some time, I hope it is okay to
post it here.

The crash happens inside PyGlade shared library because for some reason
gtk.glade.XML() loads translation in current locale instead of UTF-8 (Gtk
understands only UTF-8). Adding two calls to gtk.glade.bindtextdomain() and
gtk.glade.textdomain() before loading the glade file fixes the problem,
althought I'm not quite sure why PyGlade doesn't always use UTF-8 as Gtk does
not understand any other encoding.

I have built a test rpm with this patch and it works without any flaw. I have
tried to run it with the following locales:

C
en_US.UTF-8
ru_RU.UTF-8
ru_RU.KOI8-R
ru_RU.CP1251
ro_RO.UTF-8
ro_RO.iso8859-2

and it worked fine under all these locales.

The patch also depends of the patched system-config-network, I have posted the
patch in bug #233898. The problem is that NC_functions.py initialize the
gettext() function with the wrong encoding. In any case, even if the patch in
#233898 is not applied, system-config-network won't crash anymore, but will
display question marks instead of translated messages if locale encoding is not
UTF-8. If it's UTF-8 it will run perfectly.
Comment 1 Andrew Zabolotny 2008-03-31 18:29:07 EDT
Created attachment 299779 [details]
The diff against 1.0.12 sources
Comment 2 Bug Zapper 2008-11-26 05:19:51 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Bug Zapper 2009-01-09 01:17:44 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.