Bug 440019 - Save to remote host button missing
Save to remote host button missing
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-01 08:33 EDT by Alexander Todorov
Modified: 2011-01-24 17:48 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-12 09:24:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screen dump of UI (30.03 KB, image/png)
2008-04-01 08:35 EDT, Alexander Todorov
no flags Details
screen dump of UI with the 'Save to Remote' present (76.07 KB, image/png)
2008-04-01 12:26 EDT, Alexander Todorov
no flags Details
traceback.png (IBM Power5 Install) (54.25 KB, image/png)
2008-04-21 07:23 EDT, James Laska
no flags Details

  None (edit)
Description Alexander Todorov 2008-04-01 08:33:48 EDT
Description of problem:
When a traceback occurs in anaconda the user is presented with a dialog and
several options: Reboot, Debug and Save to remote host. The "Save to remote"
button is not always present.

Version-Release number of selected component (if applicable):
anaconda-11.1.2.108-1
RHEL5.2-Server-20080326.0

How reproducible:
100%

Steps to Reproduce:
1) boot from DVD (ia64) (xen hvm, 512 MB memory)
2) start VNC install
3) choose default install
4) select "Customize packages"
5) choose all package groups
6) When anaconda tries to format partitions the traceback happens (bug #435271)

  
Actual results:
The error dialog doesn't have the 'Save to remote' button

Expected results:
The error dialog has a 'Save to remote' button so the user can save the
traceback prior to rebooting.

Additional info:
Comment 1 Alexander Todorov 2008-04-01 08:35:53 EDT
Created attachment 299882 [details]
screen dump of UI
Comment 4 Alexander Todorov 2008-04-01 12:26:36 EDT
Created attachment 299919 [details]
screen dump of UI with the 'Save to Remote' present

5.1 GA dump shows that the save button is present but it was produced with
other steps to reproduce. The ones described in comment #0 are not applicable
to 5.1 GA.

A wild guess is that the error dialog is initialized every an error is handled
in the code and sometimes the buttons are not set up properly.
Comment 5 Alexander Todorov 2008-04-01 12:36:51 EDT
info from jgranados:
In the case where we're installing from physical media and have no network
enabled it's logical the Save button to be missing. In the case where we have
network enabled(5.1 case) the Save button is there. 

I'll do some more testing tomorrow to confirm if the above is true or not. In
the meanwhile I'd appreciate if developers confirm that this is by design.

Thanks.
Comment 6 Peter Jones 2008-04-01 17:12:29 EDT
This is a bug, but it's not something that I think we need to put a priority on,
especially in RHEL.  We should fix this in Fedora, so the fix will make it to
RHEL someday, but there's no reason it should ever be a blocker for RHEL.
Comment 7 Jeff Bastian 2008-04-01 17:17:22 EDT
(In reply to comment #5)
> In the meanwhile I'd appreciate if developers confirm that this is by design.

I'm not an anaconda developer, but this appears to be by design.  Look at gui.py
in the anaconda sources, find the ExceptionWindow class and look at the __init__
constructor:

        # Remove the floppy button if we don't need it.
        if not floppy.hasFloppyDevice() and not flags.debug:
            buttonBox = exnxml.get_widget("buttonBox")
            floppyButton = exnxml.get_widget("floppyButton")
            buttonBox.remove(floppyButton)

        # Remove the remote button if there's no network.
        if not hasActiveNetDev() and not flags.debug:
            buttonBox = exnxml.get_widget("buttonBox")
            remoteButton = exnxml.get_widget("remoteButton")
            buttonBox.remove(remoteButton)

So, you either need a floppy or a configured network device, or you need to pass
in 'debug' on the anaconda command line, in order to enable the save buttons.
Comment 9 Joel Andres Granados 2008-04-18 09:13:15 EDT
As I see it, anaconda is doing what it is supposed to. When there is network,
there is a button,  when there is floppy there is a floppy button, If there is
none.  no button present.
What is the required behavior?
Comment 10 Jeff Bastian 2008-04-18 16:32:17 EDT
IBM-LTC says that they're doing a network install (which, obviously, means the
network is active), but when anaconda crashes, the 'Save' button is missing.

They're on ppc hardware.  Maybe there's a bug with how anaconda is detecting if
the network is active on ppc?  I have not yet a chance to try and duplicate this
myself on ppc hardware.

I'm also assuming this is in an LPAR with ibmveth network interface.
Comment 11 Alexander Todorov 2008-04-21 04:17:02 EDT
IIRC the original bug report was against Xen HVM guest which also had networking
enabled but the Save to remote host button was missing. We have to look at the
code that detects the network/floppy and seek for possible errors.
Comment 12 James Laska 2008-04-21 07:23:50 EDT
Created attachment 303135 [details]
traceback.png (IBM Power5 Install)

Attaching screenshot of a forced traceback on a RHEL5.2-Server-20080416.0/ppc
install

Buttons displayed are: 
 * Save to Remote
 * Debug
 * OK
Comment 13 Joel Andres Granados 2008-06-12 09:06:29 EDT
There is no consistent reproducer for this issue.  
Comment #1 shoes it *not* to be present, but it was a CD install.  So its sane
to say that its not suppose to be there.
comment #12 states that the present. 
comment #10 states that it was reproduced.

What are the specifics of the system from comment #12 and #10.
Going to nack it for 5.3
Comment 14 RHEL Product and Program Management 2008-06-12 09:24:06 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request. 

Note You need to log in before you can comment on or make changes to this bug.