Bug 440037 - Resolution fixed at 320x200
Resolution fixed at 320x200
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-01 10:35 EDT by Lennart Poettering
Modified: 2008-04-11 05:12 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-11 05:12:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.log (271.62 KB, application/octet-stream)
2008-04-01 10:50 EDT, Lennart Poettering
no flags Details
xorg.conf (608 bytes, application/octet-stream)
2008-04-01 10:51 EDT, Lennart Poettering
no flags Details

  None (edit)
Description Lennart Poettering 2008-04-01 10:35:17 EDT
Upgraded to rawhide yesterday (xorg-x11-drv-ati-6.8.0-8.fc9.x86_64)

Since then my dual-head setup on RV630 doesn't work anymore. Although xrandr
claims it found both screens and configured them to the native resolution only
the left one (DVI-0) actually is enabled and to a resolution of 320x200 (or
something similarly small). The virtual screen seems to be set up correctly
however, I can only see the upper leftmost part of the virtual screen.

Playing around with xrandr and switching resolutions doesn't have any effect.
xrandr will always claim that it executed what i asked it for, however, only the
left screen stays enabled always on physical 320x200.
Comment 1 Lennart Poettering 2008-04-01 10:50:57 EDT
Created attachment 299907 [details]
Xorg.log
Comment 2 Lennart Poettering 2008-04-01 10:51:16 EDT
Created attachment 299908 [details]
xorg.conf
Comment 3 Lennart Poettering 2008-04-01 14:27:53 EDT
BTW, downgrading to -6 solved the problem. -7 was broken in the same way.
Comment 4 Matěj Cepl 2008-04-01 18:04:51 EDT

*** This bug has been marked as a duplicate of 429183 ***
Comment 5 Dave Airlie 2008-04-01 20:43:05 EDT
hmm wierd can you try -9 when it lands or from koji and let me know.

quite a bit changed between -6 and -7 and maybe something else broke..
Comment 6 Lennart Poettering 2008-04-03 15:06:26 EDT
I tried -9 now. Nothing changed. Same issue.

BTW. I reopened this issue, because I believe  that 429183 is a different issue.
My issues on ATI, the other bug is on intel.

(Oh, to get X after the upgrade running I had to move the glx module out of the
way, otherwise X would segfault when initializing it. But that's a different issue)
Comment 7 Dave Airlie 2008-04-09 00:18:48 EDT
can you try -10?

I think upstream fixed this.
Comment 8 Lennart Poettering 2008-04-10 18:22:27 EDT
-10 seems to work fine. The screens where initialized in a crazy way at first
after login (might be due to some old config settings?), but xrandr fixed it.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.