Bug 440091 - init segfaults at boot on system upgraded from F8
init segfaults at boot on system upgraded from F8
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
: 440514 (view as bug list)
Depends On:
Blocks: F9Blocker
  Show dependency treegraph
 
Reported: 2008-04-01 14:16 EDT by Will Woods
Modified: 2008-04-17 02:29 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-17 02:29:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Will Woods 2008-04-01 14:16:01 EDT
I upgraded my system from F8 to rawhide using preupgrade.

At boot I get the following message from init:

init[1]: segfault at d ip 004a266b sp bfa52b60 error 4 in
libc-2.7.90.so[48c000+16d000]

Bootup hangs at this point.
Comment 1 Bill Nottingham 2008-04-01 14:17:27 EDT
What happens if you boot with enforcing=0/selinux=0?

If you boot with init=/bin/bash and do:

rpm -V upstart event-compat-sysv

what do you see?
(In reply to comment #0)
> I upgraded my system from F8 to rawhide using preupgrade.
> 
> At boot I get the following message from init:
> 
> init[1]: segfault at d ip 004a266b sp bfa52b60 error 4 in
> libc-2.7.90.so[48c000+16d000]
> 
> Bootup hangs at this point.

Comment 2 Will Woods 2008-04-01 14:27:39 EDT
All combinations of those boot args give slightly different SPs but that's it.

e.g. selinux=0 init=/bin/bash:
init[1]: segfault at d ip 004a266b sp bfacb960 error 4 in
libc-2.7.90.so[48c000+16d000]

Trying to get a working rescue CD so I can poke this machine a bit further.
Comment 3 Bill Nottingham 2008-04-01 15:02:37 EDT
Well, that eliminates upstart as the culprit.
Comment 4 Jeremy Katz 2008-04-01 15:58:46 EDT
Is that init or is it /init  from the initrd (in which case, nash)?
Comment 5 Bill Nottingham 2008-04-01 16:28:44 EDT
Poked at the box. It's the return of the 'mkinitrd chooses mismatching ld.so and
libc' problem.
Comment 6 Jeremy Katz 2008-04-01 19:37:08 EDT
Blargh.  This is because ld-2.7.90.so sorts before ld-2.7.so in shell sort.  But
we don't want to change the sort to be reversed as that would break things for
ld-2.7 -> ld-2.8.  Not really sure if there's any better heuristic to use
off-hand :-/
Comment 7 Bill Nottingham 2008-04-02 11:35:24 EDT
Can't we just readlink ld-linux.so.2?
Comment 8 Jeremy Katz 2008-04-02 11:53:24 EDT
The name isn't consistent across arches...  it's ld-linux-x86_64.so.2 on x86_64,
ld-linux-ia64.so.2 on itanium, ld.so.1 on ppc and ld64.so.1 on ppc64.  I didn't
feel motivated enough to find an s390 or a sparc at that point.  And keeping a
hardcoded list in mkinitrd per-arch feels like loss
Comment 9 Bill Nottingham 2008-04-02 14:21:56 EDT
You don't need a list, you can just ldd something...
Comment 10 Adam Jackson 2008-04-03 14:51:35 EDT
(In reply to comment #9)
> You don't need a list, you can just ldd something...

Like say, the libc you're about to install.
Comment 11 Dave Jones 2008-04-03 21:06:20 EDT
*** Bug 440514 has been marked as a duplicate of this bug. ***
Comment 12 Dave Jones 2008-04-04 13:07:51 EDT
*** Bug 440583 has been marked as a duplicate of this bug. ***
Comment 13 Need Real Name 2008-04-04 13:17:29 EDT
kernel-2.6.25-0.195.rc8.git1.fc9.i686 wfm
Comment 14 Will Woods 2008-04-04 13:25:47 EDT
Yes, anything that recreates the initrd (e.g. installing a new kernel)
post-upgrade will work fine. 

But the problem happens when you run mkinitrd *during* the upgrade.
Comment 15 Peter Jones 2008-04-07 10:46:22 EDT
Can you test this with 6.0.42 ?  (to be built very soon...)
Comment 16 Jeremy Katz 2008-04-17 02:29:00 EDT
Just did an upgrade from F8 and things are fine now

Note You need to log in before you can comment on or make changes to this bug.