Bug 440148 - traceback upgrading from F8 to F9beta
traceback upgrading from F8 to F9beta
Status: CLOSED DUPLICATE of bug 438830
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Blocker
  Show dependency treegraph
 
Reported: 2008-04-01 17:55 EDT by Will Woods
Modified: 2008-04-01 18:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-01 18:39:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anacdump.txt from attempted upgrade (606.11 KB, text/plain)
2008-04-01 17:55 EDT, Will Woods
no flags Details

  None (edit)
Description Will Woods 2008-04-01 17:55:16 EDT
After upgrading an x86_64 system from F8 using the F9Beta DVD, when anaconda
tried to configure the bootloader, it threw an exception and died.

The traceback is:

anaconda 11.4.0.55 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.5/posixpath.py", line 171, in exists
    st = os.stat(path)
  File "/usr/lib/anaconda/isys.py", line 765, in readFSType
    if not os.path.exists(device):
  File "/usr/lib/booty/bootloaderInfo.py", line 65, in syncDataToDisk
    if isys.readFSType(dev) == "xfs":
  File "/usr/lib/booty/bootloaderInfo.py", line 637, in runGrubInstall
    syncDataToDisk(bootDev, "/boot", instRoot)
  File "/usr/lib/booty/bootloaderInfo.py", line 1077, in upgradeGrub
    self.runGrubInstall(instRoot, bootDev, cmds, cfPath)
  File "/usr/lib/booty/bootloaderInfo.py", line 1099, in write
    chainList, defaultDev, justConfig)
  File "/usr/lib/booty/bootloaderInfo.py", line 1215, in write
    chainList, defaultDev, justConfig, intf)
  File "/usr/lib/anaconda/bootloader.py", line 229, in writeBootloader
    justConfigFile, anaconda.intf)
  File "/usr/lib/anaconda/dispatch.py", line 208, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 131, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1246, in nextClicked
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 80, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 1267, in handleRenderCallback
    self.currentWindow.renderCallback()
TypeError: coercing to Unicode: need string or buffer, instance found

Local variables in innermost frame:
path: fsentry -- device: sda1   mountpoint: /boot
  fsystem: ext3 format: 0
  ismounted: 1  options: 'defaults'
  label: None fsprofile: None

full anacdump.txt is attached.
Comment 1 Will Woods 2008-04-01 17:55:16 EDT
Created attachment 299976 [details]
anacdump.txt from attempted upgrade
Comment 2 Will Woods 2008-04-01 18:03:41 EDT
The system needed a fsck on reboot but seems to actually be booting F9beta OK.
So this doesn't *break* installs, at least.
Comment 3 Jeremy Katz 2008-04-01 18:39:01 EDT

*** This bug has been marked as a duplicate of 438830 ***

Note You need to log in before you can comment on or make changes to this bug.