Bug 440149 - No need libgnomeui-devel to build libcroco
No need libgnomeui-devel to build libcroco
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libcroco (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-01 17:57 EDT by Christian Tosta
Modified: 2008-04-01 18:59 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-01 18:59:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to spec file version 0.6.1-4. (115 bytes, patch)
2008-04-01 18:00 EDT, Christian Tosta
no flags Details | Diff

  None (edit)
Description Christian Tosta 2008-04-01 17:57:41 EDT
Description of problem:
spec file for libcroco buildrequires libgnomeui-devel, but none 
of sources files in libcroco includes any header from libgnomeui.

Version-Release number of selected component (if applicable):
0.6.1-4

How reproducible:
Ever

Steps to Reproduce:
1.download libcroco srpm from rawhide
2.try to build libcroco without libgnomeui-devel installed
3.build srpm with rpmbuild --rebuild --nodeps libcroco.srpm
  
Actual results:
Failed build dependencies:
        libgnomeui-devel is needed by libcroco-0.6.1-4ekt3.i386

Expected results:
Compile libcroco

Additional info:
This is high because libgnomeui-devel downloads lots of dependencies
not needed to build against current libcroco.
Comment 1 Christian Tosta 2008-04-01 18:00:06 EDT
Created attachment 299979 [details]
Patch to spec file version 0.6.1-4.
Comment 2 Christian Tosta 2008-04-01 18:02:58 EDT
Comment on attachment 299979 [details]
Patch to spec file version 0.6.1-4.

--- libcroco.spec.orig	2008-04-02 00:55:35.755092994 -0300
+++ libcroco.spec	2008-04-02 01:00:29.571289498 -0300
@@ -1,7 +1,7 @@
 Name:		   libcroco
 Summary:	   A CSS2 parsing library
 Version:	   0.6.1
-Release:	  4%{?dist}
+Release:	  5%{?dist}
 License:	   LGPLv2
 Group: 	   System Environment/Libraries
 Source:	   %{name}-%{version}.tar.bz2
@@ -14,7 +14,6 @@
 BuildRequires:    glib2-devel >= 2.3
 BuildRequires:    pango-devel >= 1.3
 BuildRequires:    libxml2-devel >= 2.4.23
-BuildRequires:    libgnomeui-devel

 %description
 CSS2 parsing and manipulation library for GNOME
@@ -28,7 +27,6 @@
 Requires:	   glib2-devel >= 2.0
 Requires:	   libxml2 >= 2.4.23
 Requires:	   libxml2-devel >= 2.4.23
-Requires:	   libgnomeui-devel

 %description devel
 This package provides the necessary development libraries and include
@@ -76,6 +74,9 @@
 %{_libdir}/pkgconfig/libcroco-0.6.pc

 %changelog
+* Tue Apr 01 2008 Christian Tosta <tosta@users.sf.net> - 0.6.1-5
+- No need libgnomeui-devel for BR and -devel
+
 * Fri Feb  8 2008 Matthias Clasen <mclasen@redhat.com> - 0.6.1-4
 - Rebuild for gcc 4.3

Note You need to log in before you can comment on or make changes to this bug.