This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 440280 - postfix tries (and fails) to start before NetworkManager
postfix tries (and fails) to start before NetworkManager
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: F9Target
  Show dependency treegraph
 
Reported: 2008-04-02 12:09 EDT by Rex Dieter
Modified: 2008-04-08 20:51 EDT (History)
3 users (show)

See Also:
Fixed In Version: 8.69-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-08 20:51:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2008-04-02 12:09:12 EDT
Using NetworkManger, per F-9 default.

On boot, I see:

Starting postfix:  failed

/var/log/maillog contains
postfix/sendmail[...]: fatal: could not find any active network interfaces

Which is probably true, since it tries to start before NetworkManager.
Comment 1 Thomas Woerner 2008-04-02 12:37:27 EDT
Is there no local network interface?
Comment 2 Rex Dieter 2008-04-02 12:41:15 EDT
Apparently not until NetworkManager starts.
Comment 3 Thomas Woerner 2008-04-02 12:53:55 EDT
Then this is a NetworkManager bug. You can not start any network service without
at least local network.

Assigning to NetworkManager.
Comment 4 Rex Dieter 2008-04-02 13:05:28 EDT
fair nuf.

Not that you mention it, this may be self-inflicted, since this is an updated
box from early in the F9 dev cycle, I manually
chkconfig network off
chkconfig NetworkMananager on
awhile back.  

Should network service be enabled or disabled?  (will try it enabled to see what
happens).
Comment 5 Rex Dieter 2008-04-02 13:14:21 EDT
confirmed, with both 'network' and 'NetworkManager' services running, things
work as expected/advertised.

I'll close this.  Move along, nothing to see here.
Comment 6 Warren Togami 2008-04-02 13:17:41 EDT
Things are supposed to work with NetworkManager and without network.  Reopening.
Comment 7 Dan Williams 2008-04-02 21:32:56 EDT
was talking with notting about this today; there are two circular deps if we'd
try to start NM earlier.  The first is that dbus depends on syslog, but syslog
depends on network.  bascially sysvinit and lsb suck.  not much we can do here
until we get a better init system.
Comment 8 Bill Nottingham 2008-04-03 11:13:58 EDT
We could always bring up loopback somewhere else. That actually fits the broken
LSB definition of 'network'....
Comment 9 Colin Walters 2008-04-03 15:51:23 EDT
Also could have a smarter syslog that queues up messages until the network is
available.
Comment 10 Rex Dieter 2008-04-04 07:28:17 EDT
see also #bug #439242
Comment 11 Rex Dieter 2008-04-06 12:44:22 EDT
Seems recent fixes (in initscripts) to address bug #439242 has also resolved
this for me (postfix starts now anyway).
Comment 12 Bill Nottingham 2008-04-07 12:06:17 EDT
That's strange; it should be mostly unrelated.
Comment 13 Rex Dieter 2008-04-08 10:12:03 EDT
nevermind.  rechecked, and my comment #11 is incorrect.  still a problem alright.
Comment 14 Rex Dieter 2008-04-08 20:51:25 EDT
initscripts-8.69-1 confirmed mm, mm, good.

Note You need to log in before you can comment on or make changes to this bug.