Bug 440298 - RFE: Need script to silently install/remove DS and Dogtag instances
Summary: RFE: Need script to silently install/remove DS and Dogtag instances
Status: CLOSED WONTFIX
Alias: None
Product: Dogtag Certificate System
Classification: Retired
Component: CA (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
low
Target Milestone: 1.0
Assignee: Matthew Harmsen
QA Contact: Chandrasekar Kannan
URL:
Whiteboard:
Keywords: FutureFeature
: 440157 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-04-02 17:49 UTC by Bob Lord
Modified: 2015-01-04 23:31 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-08 19:33:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bob Lord 2008-04-02 17:49:49 UTC
Description of problem:
I would like to have a single command to install DS and Dogtag with some
pre-arranged values.  I would also like a single command to delete both
instances so I can repeat this process many times and very quickly.

These tools would be very useful for setting up demos and for QA.

Version-Release number of selected component (if applicable):
1.0.0

Comment 1 Matthew Harmsen 2008-04-02 18:27:17 UTC
The following comments were merged from a previously duplicated bug:

IPA provides an installation/uninstallation tools which asks the user a set of
simple questions, and proceeds to install and configure a complete IPA solution.
 Additionally, this tool provides the means of completely uninstalling the
entire IPA solution.

CS needs to provide a similar solution which optionally installs/uninstalls and
configures a DS as well as the associated CS subsystems.  This script will
probably make use of the pkisilent RPM.



Comment 2 Matthew Harmsen 2008-04-02 18:27:48 UTC
*** Bug 440157 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.