Bug 440312 - Fedora9 beta - can't install from LiveCD
Summary: Fedora9 beta - can't install from LiveCD
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 440313 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-04-02 18:58 UTC by Gary Thomas
Modified: 2008-04-08 03:24 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-08 03:24:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda dump/log (15.56 KB, text/plain)
2008-04-02 18:58 UTC, Gary Thomas
no flags Details

Description Gary Thomas 2008-04-02 18:58:22 UTC
Description of problem:

Can't install from LiveCD

Version-Release number of selected component (if applicable):

Fedora 9, Beta, LiveCD

How reproducible:

100%

Steps to Reproduce:
1. Just run 'liveinst'
2. Choose 'replace all' or 'replace linux' partitions
3.
  
Actual results:

Anaconda throws exception trying to [re]build logical volume layout.

Expected results:


Additional info:

It might be a problem with my small system (192KB) that has an existing
Fedora install.  I just wanted to completely overwrite with the beta.

Comment 1 Gary Thomas 2008-04-02 18:58:22 UTC
Created attachment 300116 [details]
anaconda dump/log

Comment 2 Jeremy Katz 2008-04-03 02:58:13 UTC
I'm impressed you even managed to boot the live CD on a box with 192M of RAM :-)

Did /dev/sda2 exist when the traceback happened?  I'm guessing that based on the
memory pressure, udev was slow to respond and create the devices.  I committed
something yesterday which should help that situation a bit if so.

Comment 3 Jeremy Katz 2008-04-03 02:58:20 UTC
*** Bug 440313 has been marked as a duplicate of this bug. ***

Comment 4 Gary Thomas 2008-04-03 10:57:32 UTC
I've been happily running Fedora on this laptop for a lone time.  It's too bad
that things have grown so out of hand that I can barely run the LiveCD on it.

As for the disk layout before I ran liveinst - I've tried it many ways; with an
extant Fedora installation or with an empty disk label.  I also tried to
configure my own layout which failed even more spectacularly.

How can I test your recent changes (comment #2)?


Comment 5 Jeremy Katz 2008-04-03 13:33:12 UTC
The livecd actually has higher memory requirements as changes to the filesystem
are kept around using a RAM based dm-snapshot device.  And we'll have up a
snapshot release which will include the changes either later today or tomorrow

Comment 6 Gary Thomas 2008-04-05 15:33:34 UTC
Rawhide-20080404-Snapshot-i686-Live managed to boot & install (text mode)
I only tried the 'remove all & setup default' partition mode.

Note firstboot failed after install :-(  See 441049
Can't login - tty messed up :-( - See 441048
Skipping that, going to init 5, system frezzes :-( - See 441051

Comment 7 Jeremy Katz 2008-04-08 03:24:45 UTC
Sounds like the anaconda bug at least is fixed


Note You need to log in before you can comment on or make changes to this bug.