Bug 440324 - Installation failed on laptop Panasonic Toughbook CF-52
Installation failed on laptop Panasonic Toughbook CF-52
Status: CLOSED DUPLICATE of bug 437993
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-02 16:03 EDT by Alain Portal
Modified: 2008-04-03 13:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-02 23:10:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alain Portal 2008-04-02 16:03:04 EDT
Description of problem:

Installation of F9Test [1] failed on laptop Panasonic Toughbook CF-52 (ATI 
X2100)

The graphical boot work.
Graphical installation freeze with the X Server, Ctrl+F? and Ctrl-Alt+Back are 
unavailable. To restart, the is no other way than unplugged the laptop.

Laptop is booted with an usb key connected to have a support to save the 
anaconda report.
Probing for video card: ATI Technologies Inc M71 [Mobility Radeon X2100]
Choosen installation language is french and keyboard is us
Text installation failed with the following message :

anaconda 11.4.0.55 exeception report
Traceback (most recent call first):
  File
"/usr/lib/anaconda/textw/network_text.py",
line 511, in chooseNetworkDevice
    "interfface in you system?") %
(devs[0],),
  File
"/usr/lib/anaconda/textw/network_text.py",
line 613, in __call__
    dev = self.chooseNetworkDevice(screen)
  File "/usr:lib/anaconda/text.py", line
678, in run
    rc = win(self.screen, instance)
  File "/usr/lib/anaconda", line 1046, in
<module>
    anaconda.intf.run(anaconda)
UnicodeDecodeError: 'ascii' codec can't
decode byte 0xc3 in position 17: ordinal
not in range(128)

If I try to save the report, I get the following bug :

Assertion (ped_partition_is_active
(part)) at disk.c:1186 in function
ped_partition_get_flag() failed.

If I choose to ignore, I get the following bug :

Assertion (part->disk_specific !=
NULL) at dos.c:1423 in function
msdos_partition_get_flag() failed.

If I choose to ignore, I have to restart laptop.

If the choosen installation language is french and keyboard is us,
Text installation don't fail at the same place but latter.
Message error is longer, and too long to rewrite it...

Top is:
File "/usr:lib/anaconda/yuminstall.py",
line 160, in callback,
    s += (hdr['summary'] or "")

Bottom is :
UnicodeDecodeError: 'ascii' codec can't
decode byte 0xc2 in position 19: ordinal
not in range(128)

[1] (http://torrent.fedoraproject.org/torrents//Fedora-9-Beta-i386.torrent)
Comment 1 Jeremy Katz 2008-04-02 23:10:44 EDT
Please, please, please file different reports for different bugs.  It's nearly
impossible to accurately track and ensure that things are fixed otherwise.

For the first, please file a new report with specific details about your
graphics hardware against xorg-x11-drv-ati.  The parted one I think I saw the
fix go in for and the last is a duplicate and I'm marking this as such

*** This bug has been marked as a duplicate of 437993 ***
Comment 2 Alain Portal 2008-04-03 13:22:04 EDT
(In reply to comment #1)
> Please, please, please file different reports for different bugs.  It's 
nearly
> impossible to accurately track and ensure that things are fixed otherwise.

Sorry, it was in case if all problems were consecutive.

I'll open bugs.

Note You need to log in before you can comment on or make changes to this bug.