This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 440478 - 2.6.24.4-64.fc8 iwl3945 radio "on" lamp flashes irratically
2.6.24.4-64.fc8 iwl3945 radio "on" lamp flashes irratically
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
: Reopened
: 449733 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-03 14:14 EDT by Alistair
Modified: 2008-07-15 11:13 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-08 16:03:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alistair 2008-04-03 14:14:59 EDT
Description of problem:

The radio-on light for the iwl3945 wireless card flashes or stays on steadily 
during operation of the latest kernel.  

Version-Release number of selected component (if applicable):

2.6.24.4-64.fc8

How reproducible:

Simply use the iwl3945 wireless kernel module to drive the wireless card.
  
Actual results:

Irritating flashing light.

Expected results:

Light steadily on when the radio is on, and light steadily off when radio is 
off.

Additional info:

Previous versions of iwl3945 did not turn the light on at all.  Although that 
was is not correct behaviour, it is much less annoying than having the light 
flash!
Comment 1 Carlo de Wolf 2008-04-04 02:31:33 EDT
Same on i686
Comment 2 Matthias Saou 2008-04-24 07:53:21 EDT
...this is triggered by a new kernel, yet you report it against the firmware
package? Reassigning to the kernel maintainers. Please confirm if this is still
happening with the latest F-8 updated kernel.
Comment 3 Alistair 2008-04-24 08:18:17 EDT
(In reply to comment #2)
> ...this is triggered by a new kernel, yet you report it against the firmware
> package? Reassigning to the kernel maintainers. Please confirm if this is 
still
> happening with the latest F-8 updated kernel.

Yes, it is still happening with 2.6.24.4-64.fc8.  I have also tried 
2.6.24.5-85.fc8 from Koji, and that is the same.

A
Comment 4 John W. Linville 2008-04-24 09:09:13 EDT
Flashing lights are used to indicate traffic and other status of the device -- 
this is perfectly normal.
Comment 5 Carlo de Wolf 2008-04-24 09:21:47 EDT
If it's not a bug, then it's a feature regression. The problem remains.

For those of us who have the light right in front of the LCD it's a pita.

Please create an option for a steady light (e.g. reintroduce the previous bug
:-) ) when the radio is on.
Comment 6 Alistair 2008-04-24 09:53:29 EDT
(In reply to comment #4)
> Flashing lights are used to indicate traffic and other status of the 
device -- 
> this is perfectly normal.

Well someone should file a bug against Intel's Windows driver, because in that 
OS, the light is on and steady when the radio is on and off otherwise :-)

Seriously, with respect, I don't think that is correct (do you have 
documentation to confirm?).  Yes, I know that many NICs use a light to 
indicate status activity, but not in this case, for several reasons:

a) the flashing bears no relation that I can tell to network activity: it 
seems random;
b) it is not like an activity light on a wired NIC: it is much slower, with 
flashes variably at between about 0,5 and 2 Hz, with roughly equal 
mark-to-space ratio;
c) the manufacturer's drivers' behaviour, mentioned above; and
d) no-one would have created something quite so annoying.  This is a *bright* 
blue flashing light right in the user's line-of-sight.

A
Comment 7 Alistair 2008-04-24 10:01:17 EDT
Oh, and the Intel-developed Linux ipw3945 driver also had the light steady on 
or off.

A
Comment 8 John W. Linville 2008-04-24 10:06:28 EDT
Perhaps you are unaware that Intel develops this driver?
Comment 9 Alistair 2008-04-25 15:09:16 EDT
I did not know that!

Anyway, I have done some research.  Looking at the wireless manual for my
computer (HP nx7400), which you can get at
http://bizsupport.austin.hp.com/bc/docs/support/SupportManual/c00820096/c00820096.pdf

to quote:

"The wireless light indicates the overall power state of your wireless devices,
not the status of individual devices. If the wireless light is blue, at least
one wireless device is turned on. If the wireless light is turned off, all
wireless devices are turned off."

I think that is clear.  Flashing is wrong: it is a bug.

Thanks for your attention.

HTH
A
Comment 10 John W. Linville 2008-04-28 10:31:23 EDT
You are welcome to your opinion about whether or not it should flash.  
However, you will forgive me if I do not cede to HP the decision as to how 
everyone's LEDs should work. :-)

I'll leave this open for now as a reminder to bug (no pun intended) Intel 
about whether or not the current behavior is annoying.  FWIW, I think at least 
some flashing to indicate wireless activity is completely appropriate.  I will 
allow for the possibility that the current flashing parameters are 
undesirable.
Comment 12 Carlo de Wolf 2008-04-28 10:55:23 EDT
Dell has it as non-flashing:
http://support.dell.com/support/edocs/systems/latd820/en/ug/about.htm#wp1174420

:-P
Comment 13 John W. Linville 2008-06-04 14:52:35 EDT
*** Bug 449733 has been marked as a duplicate of this bug. ***
Comment 14 John W. Linville 2008-07-08 16:03:32 EDT
Well, I'm sorry this behavior is not to your taste.  But I don't think we are
going to change it.
Comment 15 Alistair 2008-07-15 11:13:53 EDT
Oh, well.  Time for some kernel hacking for me, then :-o

A

Note You need to log in before you can comment on or make changes to this bug.