Bug 44052 - anaconda fatal error: backup to edit mount points
anaconda fatal error: backup to edit mount points
Status: CLOSED DUPLICATE of bug 18251
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-10 18:01 EDT by John Reiser
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-10 22:45:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2001-06-10 18:01:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.19-6.2.1 i586)

Description of problem:
Anaconda detected a fatal error after I backed up from just before
"formatting partitions", all the way back to edit the mount points,
then tried to go forward again.  I saved the error info
onto a floppy, then gave a hardware Reset, and started over
from the beginning.

New install of RH7.0 on i386, using the back 12G of a 20G disk.
Front 8G (BIOS limitations) has 80M Linux native 83 (planning
ahead for /boot), 1G FAT for Win95, 7G Extended containing
2G FAT32, 4.5G FAT32, 0.5G free.

I used fdisk from tomsrtbt 1.7.185 to turn the Extended (type 5;
8GB limit) into an Extended (type F; Win95 LBA entire rest of disk).
[Delete all logical parititions, delete Extended type 5, create
new Extended, change to type F, re-create (in place) two FAT32
type B. Win95 was still happy (Phew!)]

Then I booted from RH7.0 floppy (BIOS cannot boot CD-ROM, either),
Manual Partitioning, asked for 2G root, 5G /home, 400M swap,
leaving 3.5G free.  Note that I forgot to mount /boot on hda1.
The machine has only 32M of RAM, so partition table had to be written
"early".

I got all the way to Formatting Partitions, then realized that
I needed to mount /boot.  So I went Back many screens (text install),
mounted /boot on hda1, then tried to go forward.  Anaconda
detected a fatal error, and would not proceed.

I thought I was going to get a graphical install (Enter
at first input screen).  The questions about language,
keyboard, and mouse were all in the text install format.
I choose Manual Partitioning as soon as I could.  Maybe
that switched me into text install. (No real problem; I'm
just somewhat confused as to how I got into text install
when I thought I asked for graphical.)

How reproducible:
Didn't try

Steps to Reproduce:
1. See Desription for what I did.
2.
3.
	

Actual Results:  Contents of floppy written by Anaconda:
Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in
run
    rc = apply (step[1](), step[2])
  File
"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/textw/partitioning_text.py",
line 224, in __call__
    todo.fstab.savePartitions ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 220, in
savePartitions
    sys.exit(0)
NameError: sys

Local variables in innermost frame:
self: <fstab.NewtFstab instance at 820a388>

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>


Expected Results:  Ability to proceed forward, and complete the
installation,
despite having to back up from "formatting partitions",
to the screen for editing mount points.

Additional info:
Comment 1 Brent Fox 2001-06-10 22:45:15 EDT

*** This bug has been marked as a duplicate of 18251 ***

Note You need to log in before you can comment on or make changes to this bug.