Bug 440811 - FTBFS pdsh-2.11-6.fc9
FTBFS pdsh-2.11-6.fc9
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pdsh (Show other bugs)
9
All Linux
high Severity high
: ---
: ---
Assigned To: Ben Woodard
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
:
Depends On:
Blocks: FTBFS
  Show dependency treegraph
 
Reported: 2008-04-04 12:03 EDT by FTBFS
Modified: 2008-09-15 14:15 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-15 14:15:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log.bz2 (1.81 KB, application/x-bzip2)
2008-04-04 12:03 EDT, FTBFS
no flags Details
build.log.bz2 (7.96 KB, application/x-bzip2)
2008-04-04 12:03 EDT, FTBFS
no flags Details
root.log.bz2 (1.80 KB, application/x-bzip2)
2008-04-04 12:03 EDT, FTBFS
no flags Details
build.log.bz2 (7.93 KB, application/x-bzip2)
2008-04-04 12:03 EDT, FTBFS
no flags Details

  None (edit)
Description FTBFS 2008-04-04 12:03:00 EDT
pdsh-2.11-6.fc9.src.rpm Failed To Build From Source
Comment 1 FTBFS 2008-04-04 12:03:04 EDT
Created attachment 300824 [details]
root.log.bz2

root.log for i386
Comment 2 FTBFS 2008-04-04 12:03:05 EDT
Created attachment 300825 [details]
build.log.bz2

build.log for i386
Comment 3 FTBFS 2008-04-04 12:03:07 EDT
Created attachment 300826 [details]
root.log.bz2

root.log for x86_64
Comment 4 FTBFS 2008-04-04 12:03:08 EDT
Created attachment 300827 [details]
build.log.bz2

build.log for x86_64
Comment 5 Ruben Kerkhof 2008-04-19 10:16:12 EDT
The build fails in xpopen.c, because ARG_MAX is not defined in
/usr/include/limits.h, but in /usr/include/linux/limits.h

Comment 6 Ruben Kerkhof 2008-04-19 10:17:56 EDT
This is probably because of the following change in glibc:
* Fri Mar 28 23:00:00 2008 Jakub Jelinek <jakub@redhat.com> 2.7.90-13
- update to trunk
  - don't define ARG_MAX in <limits.h>, as it is no longer
    constant - use sysconf (_SC_ARG_MAX) to get the current
    argument size limit
Comment 7 Bug Zapper 2008-05-14 04:46:13 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Debarshi Ray 2008-07-05 16:08:21 EDT
Ping?
Comment 9 FTBFS 2008-09-05 12:14:47 EDT
This package has Failed to Build From Source for many months.  Per
http://fedoraproject.org/wiki/FTBFS, this package is now proposed for
removal from the distribution.  Please address this FTBFS bug
immediately, or this package will be removed from the distribution
within the next few weeks.

Thank you for your continued contributions to Fedora, and your
commitment to ensuring Fedora packages remain buildable from source
code.
Comment 10 Tom "spot" Callaway 2008-09-15 14:15:37 EDT
Fixed in rawhide:

http://koji.fedoraproject.org/koji/buildinfo?buildID=60596

Note You need to log in before you can comment on or make changes to this bug.