Bug 440964 - fails in a non-obvious way for root
fails in a non-obvious way for root
Status: CLOSED DUPLICATE of bug 446440
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-04 14:09 EDT by Bill Nottingham
Modified: 2014-03-16 23:13 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-15 13:30:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2008-04-04 14:09:09 EDT
Description of problem:

[root@nostromo ~]# pkcon refresh
Command failed
Error:
  org.freedesktop.packagekit.refresh-cache no

Usage:
  pkcon [OPTION...] PackageKit Console Program
...

While I admire the simplicity of 'no', perhaps a little more verbosity is
needed? (Not sure usage() is appropriate here.)

Version-Release number of selected component (if applicable):

PackageKit-0.1.11-0.622.20080401git.fc9.x86_64
Comment 1 Richard Hughes 2008-04-07 05:10:08 EDT
This is what we've got in git master:

[hughsie@hughsie-work gnome-packagekit]$ sudo pkcon update-system
Command failed
You don't have the necessary privileges for this operation

Is this clearer?
Comment 2 Bill Nottingham 2008-04-07 12:08:42 EDT
Well, there's the logical disconnect of:

user -> has privileges
root -> does not have privileges

I understand that some things necessarily shouldn't be done as root, but is
there a reason that you can't reschedule a refresh, or updates, or... as root?
Comment 3 Matthias Clasen 2008-04-07 17:44:21 EDT
I bet it'll work if you run a full desktop session as root
Comment 4 Bill Nottingham 2008-04-07 18:21:01 EDT
... That seems odd. After all, PacakgeKit is on the system bus, is it not?

For example, if you run *as a user* without $DISPLAY, you get:

$ pkcon refresh

** ERROR **: This program cannot start until you start the dbus system service.
aborting...
Aborted

despite the fact that the system service *is* running.
Comment 5 Andrew Farris 2008-04-08 20:33:08 EDT
If you run gpk-update-viewer as root from a terminal you get the ability to
refresh the list, and review the available updates.. but not apply them.  Both
the 'Update System' and 'Apply Updates' buttons are greyed out.

This is not authorized through sudo its by su.  That is certainly an odd
situation for the end user to try to understand.  Running gpk-update-viewer as
their normal user, with polkit auth, works but being root does not.  Everything
else about the UI functions except applying changes.
Comment 6 Andrew Farris 2008-04-08 20:36:28 EDT
Oops.  RE comment 5, root did not have polkit auth to make those changes, I
thought I had done that before.  Once the auth is given to change packages the
UI works for root just fine.
Comment 7 Thomas J. Baker 2008-04-18 16:03:56 EDT
I believe my problem is related to this bug. If not, let me know and I can open
another one.

I just did a clean preview install and logged into a root desktop session, when
I selected a package to install and clicked install from the app installer
nothing happened. No error, just nothing.

raptor> rpm -qa | grep -i packagekit
PackageKit-0.1.12-4.20080416git.fc9.x86_64
yum-packagekit-0.1.12-4.20080416git.fc9.x86_64
gnome-packagekit-0.1.12-5.20080416git.fc9.x86_64
PackageKit-libs-0.1.12-4.20080416git.fc9.x86_64
raptor> 
Comment 8 Bug Zapper 2008-05-14 04:54:56 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Robin Norwood 2008-05-15 13:30:28 EDT

*** This bug has been marked as a duplicate of 446440 ***

Note You need to log in before you can comment on or make changes to this bug.