Bug 441019 - Unable to install on usb - stick
Unable to install on usb - stick
Status: CLOSED DUPLICATE of bug 429185
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-04-05 02:23 EDT by Jóhann B. Guðmundsson
Modified: 2008-04-07 10:06 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-04-07 10:06:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Anconda out.. (65.36 KB, text/plain)
2008-04-05 09:24 EDT, Jóhann B. Guðmundsson
no flags Details

  None (edit)
Description Jóhann B. Guðmundsson 2008-04-05 02:23:18 EDT
Description of problem:

In the latest rawhide live iso 04.04

I was unable to install on a 4GB usb stick

Starting with anaconda complaining about not enough disk space
( 4096 minimun ) I press back and anaconda starts to transfer the image to 
to the usb stick???? ( another bug.. )

Then install fails in the middle of the transfer. ( another bug..)

Followed by an option for me to save the error msg which I cant
because clicking "save" crashes the application ( another bug ) 

Then I try again and I choose the partition layout ( custom layout )
no complaints about size this time, Again when transferring the image 
to the usb-stick it fails in middle of the transfer.

Anaconda needs to have a different default partition layout for size
smaller than 4096.

if less than 4096 space on selected hd then do 
boot + needed space for anaconda to install, minust total hd space = swap size

or by setting swap partition to a fixed size, ( 256. 512 or 1024 ).

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 Jóhann B. Guðmundsson 2008-04-05 09:23:33 EDT
When failing install to usb I get

An error occured trying to format sdb1. The problem is serious
.and the install cannot continue. 

Press Enter exit installer

Do this again unencrypted at this time 
get "Exception Occurered" ( see attachment which btw i copy/pasted not saved)
click save and get

Assertion (ped_partition_is active (part)) at
disk.c:1186 in function ped_partition_get_flag() failed.

Choose to ignore.. 

Assertion (part - disk_specific !=null) at dos.c:1423 in function
msdos_partition_get_flag() failed.

after that anaconda gets unresponsive
Comment 2 Jóhann B. Guðmundsson 2008-04-05 09:24:05 EDT
Created attachment 301368 [details]
Anconda out..
Comment 3 Chris Lumens 2008-04-07 10:06:51 EDT

*** This bug has been marked as a duplicate of 429185 ***

Note You need to log in before you can comment on or make changes to this bug.