Bug 429185 - failed assertion reading a USB disk during installation
failed assertion reading a USB disk during installation
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
rawhide
i386 Linux
low Severity low
: ---
: ---
Assigned To: Joel Andres Granados
Fedora Extras Quality Assurance
:
: 440981 441019 443224 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-17 15:03 EST by Chris Lumens
Modified: 2008-05-13 08:11 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-13 08:11:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
script that reproduces the error. (149 bytes, text/plain)
2008-05-10 07:58 EDT, Joel Andres Granados
no flags Details
C file that triggers the issue. (325 bytes, text/plain)
2008-05-10 09:50 EDT, Joel Andres Granados
no flags Details
patch for pyparted (1.01 KB, patch)
2008-05-10 12:20 EDT, Joel Andres Granados
no flags Details | Diff

  None (edit)
Description Chris Lumens 2008-01-17 15:03:47 EST
On the save exception dialog in anaconda, I attach a USB key and let
partedUtils.py rescan disks.  This is in exceptionDisks in partedUtils.py, I'm
assuming the lambda being passed to filter_partitions.  The following is then
encountered:

20: /lib/libparted-1.8.so.8(ped_assert+0x3b) [0xa7d81b]
19: /lib/libparted-1.8.so.8(ped_partition_get_flag+0x102) [0xa826d2]
18: /usr/lib/python2.5/site-packages/partedmodule.so [0xb7ebdf]
17: /usr/lib/libpython2.5.so.1.0(PyCFunction_Call+0x14d) [0x1857fd]
16: /usr/lib/libpython2.5.so.1.0(PyEval_EvalFrameEx+0x67e2) [0x1d2c82]
15: /usr/lib/libpython2.5.so.1.0(PyEval_EvalCodeEx+0x73f) [0x1d36cf]
14: /usr/lib/libpython2.5.so.1.0(PyEval_EvalFrameEx+0x53b4) [0x1d1854]
13: /usr/lib/libpython2.5.so.1.0(PyEval_EvalFrameEx+0x5b3d) [0x1d1fdd]
12: /usr/lib/libpython2.5.so.1.0(PyEval_EvalCodeEx+0x7ef) [0x1d36cf]
11: /usr/lib/libpython2.5.so.1.0(PyEval_EvalFrameEx+0x53b4) [0x1d1854]
10: /usr/lib/libpython2.5.so.1.0(PyEval_EvalCodeEx+0x7ef) [0x1d36cf]
9: /usr/lib/libpython2.5.so.1.0 [0x17223a]
8: /usr/lib/libpython2.5.so.1.0(PyObject_Call+0x37) [0x153167]
7: /usr/lib/libpython2.5.so.1.0 [0x15a698]
6: /usr/lib/libpython2.5.so.1.0(PyObject_Call+0x37) [0x153167]
5: /usr/lib/libpython2.5.so.1.0(PyEval_CallObjectWithKeywords+0x7c) [0x1cb87c]
4: /usr/lib/libpython2.5.so.1.0(PyInstance_New+0x6d) [0x15e3ad]
3: /usr/lib/libpython2.5.so.1.0(PyObject_Call+0x37) [0x153167]
2: /usr/lib/libpython2.5.so.1.0(PyEval_EvalFrameEx+0x3151) [0x1cf5f1]
1: /usr/lib/libpython2.5.so.1.0(PyEval_EvalFrameEx+0x5d3d) [0x1d1fdd]
Bug
Assertion (ped_partition_is_active (part)) at disk.c:1186 in function
ped_partition_get_flag() failed.
96
Comment 1 Chris Lumens 2008-04-04 15:35:22 EDT
*** Bug 440981 has been marked as a duplicate of this bug. ***
Comment 2 Chris Lumens 2008-04-07 10:06:52 EDT
*** Bug 441019 has been marked as a duplicate of this bug. ***
Comment 3 Chris Lumens 2008-04-19 10:41:52 EDT
*** Bug 443224 has been marked as a duplicate of this bug. ***
Comment 4 Joel Andres Granados 2008-05-10 07:58:22 EDT
Created attachment 305019 [details]
script that reproduces the error.

This might not be directly related to parted, but more to pyparted (not sure
yet).  What I do have is the pythong script that reproduces the bug :).
Comment 5 Joel Andres Granados 2008-05-10 09:50:08 EDT
Created attachment 305023 [details]
C file that triggers the issue.

I think its not pyparted either.  attaching a C file that also triggers the
issue.
Comment 6 Joel Andres Granados 2008-05-10 12:20:43 EDT
Created attachment 305028 [details]
patch for pyparted

pyparted needs to be a little bit more intelligent in getting to the next
partition.
Comment 7 Joel Andres Granados 2008-05-13 08:11:47 EDT
Finally fixed it in the anaconda code.  Hopefully pyparted will have some sort
of answer for this type of issues in the future.  For now this behavior does not
present itself anymore.

Note You need to log in before you can comment on or make changes to this bug.