This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 441060 - crash with UnicodeDecodeError
crash with UnicodeDecodeError
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
: 441250 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-05 13:15 EDT by Michal Schmidt
Modified: 2008-04-07 10:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-06 19:35:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Schmidt 2008-04-05 13:15:36 EDT
Description of problem:

system-config-display crashes immediately with:
Traceback (most recent call last):
  File "/usr/share/system-config-display/xconf.py", line 318, in <module>
    verbose(_("Trying with card: %s") % current_card.getDescription())
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc5 in position 4: ordinal
not in range(128)

Version-Release number of selected component (if applicable):
system-config-display-1.0.51-8.fc9.noarch
rhpxl-1.2-1.fc9.x86_64

How reproducible:
always

Steps to Reproduce:
LC_ALL=cs_CZ.UTF-8 system-config-display

Actual results:
The utility crashes with the above traceback.

Expected results:
system-config-display's dialog appears.

Additional info:
The Czech translation of "Trying with card: %s" contains non-ASCII characters:
"Zkouším kartu: %s". The translated string is of Python type 'str', but the
string returned by getDescription() is unicode. Python wants to convert the str
to unicode, but expects only ascii and crashes.
A quick fix is to change the line to:
verbose(_("Trying with card: %s") % `current_card.getDescription()`)
Comment 1 Adam Jackson 2008-04-06 19:35:37 EDT
Fixed in 1.0.51-9, thanks!
Comment 2 Adam Jackson 2008-04-07 10:01:33 EDT
*** Bug 441250 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.