Bug 441077 - Cannot select default keyboard
Summary: Cannot select default keyboard
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: control-center   
(Show other bugs)
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Control Center Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: F9Target
TreeView+ depends on / blocked
 
Reported: 2008-04-05 21:28 UTC by Need Real Name
Modified: 2008-10-05 12:52 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-05 12:52:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output as requested (1.08 KB, text/plain)
2008-04-23 21:53 UTC, Need Real Name
no flags Details

Description Need Real Name 2008-04-05 21:28:26 UTC
control-center-2.22.0-3.fc9.i386

I cannot select a default keyboard layout. I can add new keyboards to the list
of available keyboard layouts, but not click the "default" radio button.

Comment 1 Matthias Clasen 2008-04-06 15:01:46 UTC
For some reason, the radio buttons only work when you check the "Separate
layouts" checkbox. I haven't investigated why this is.

Comment 2 Need Real Name 2008-04-06 15:22:04 UTC
It means I cant tzpe the correct characters on mz kezboard.. blocker_

Comment 3 Need Real Name 2008-04-09 20:40:23 UTC
Would you like me to:

1. Delete my profile and use a new one, meaning this bug still exists, but the
bug can be closed?
2. Stick with my broken keyboard, and wait for you to fix it?


Comment 4 Ray Strode [halfline] 2008-04-10 14:47:26 UTC
Do whatever you need to get a functioning system.  We can reproduce the problem.
 We shouldn't close the bug yet though.

Comment 5 Need Real Name 2008-04-10 20:36:42 UTC
Creating a new user still has a broken keyboard.

I can't get a functioning system. I cannot use my keyboard to do anything useful
without a pipe symbol. I can't even write an e-mail address, I have no "at" sign.

Comment 6 Ray Strode [halfline] 2008-04-10 21:30:34 UTC
if you check the "Separate layout for each window" check box and change your
default, then do things work?

Comment 7 Need Real Name 2008-04-11 05:58:34 UTC
No, they don't. My numlock light comes on, but:
* the at sign
* the pipe sign
* the arrow keys
* tilde
* square brackets
do not work. 


Comment 8 Need Real Name 2008-04-18 18:11:30 UTC
So, to recap, Fedora 9 can't detect my keyboard correctly even though it worked
before, and it ignores any settings I make.

I have two problems:

1. The system-wide setting from system-config-keyboard is ignored, but when I
change it manually after every boot, it works again. When doing this I get the
message:
 Loading /lib/kbd/keymaps/i386/qwertz/de-latin1-nodeadkeys.map.gz
so I think this needs to be added to my xorg config file (which doesn't exist,
because everything is automatic, or should be..)

2. The per-user setting from that other gnome keyboard program is also ignored.
I have given up with it, and am using s-c-k every time I turn on the computer now.

It would be nice if I could plug in a keyboard and it worked :(

Comment 9 Need Real Name 2008-04-21 16:21:21 UTC
> if you check the "Separate layout for each window" check box and change your
> default, then do things work?

No. I must use s-c-k.

Comment 10 Ray Strode [halfline] 2008-04-21 18:17:20 UTC
if you add the keyboard indicator applet to your panel, what groups does it show?

Comment 11 Need Real Name 2008-04-21 18:41:24 UTC
Germany eliminate dead keys.

But I have used s-c-k since. I will reboot and see what it says without s-c-k.

Comment 12 Michael Monreal 2008-04-22 18:17:11 UTC
I'm also fighting with Fodora9Pre to get working "~" and "^" keys on a german
keyboard for days now. Other special keys like @, €, | all work for be btw.

I also see the problem described in comment #1.

Using s-c-k does _not_ change anything for me bzw. The keyboard applet does not
display anything different after running s-c-k, so I suppose the right keymap is
loaded after all... perhaps it is just broken?

Note: I tried various keyboard model and keymap combinations as well, nothing
seems to work.

Comment 13 Ray Strode [halfline] 2008-04-22 21:11:30 UTC
it seems that running setxkbmap in a terminal (with no other arguments) fixes
this issue.  This must be a problem in gnome-settings-daemon or the X server. 
Will debug more.

Comment 14 Need Real Name 2008-04-22 21:35:31 UTC
Running setxkbmap as root or non-root does nothing for me.

My keyboard is correctly qwertz before doing anything, but the @ key with
AltGr+q does not exist. Nor do the arrow keys work. Pressing delete makes me
look like an idiot - it takes a screenshot...

Comment 15 Michael Monreal 2008-04-22 22:43:00 UTC
Running this does not make a difference for me either. This is a working
xorg.conf section from my old system btw:

Section "InputDevice"
    Identifier  "Keyboard0"
    Driver      "kbd"
    Option      "XkbRules" "xorg"
    Option      "XkbModel" "pc105"
    Option      "XkbLayout" "de"
    Option      "XkbOptions" "nodeadkeys"
EndSection


Comment 16 Ray Strode [halfline] 2008-04-23 18:25:13 UTC
can you guys attach the output of

 gconftool-2 -R /desktop/gnome/peripherals/keyboard

?

Comment 17 Need Real Name 2008-04-23 21:53:39 UTC
Created attachment 303551 [details]
output as requested

Comment 18 Bug Zapper 2008-05-14 08:57:34 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 19 Peter Hutterer 2008-08-07 04:36:00 UTC
(In reply to comment #14)
> My keyboard is correctly qwertz before doing anything, but the @ key with
> AltGr+q does not exist. Nor do the arrow keys work. Pressing delete makes me
> look like an idiot - it takes a screenshot...

This is a conflict between the evdev model and pc105 model, a bug that has been fixed in rawhide. (Bug 447252)
This one here looks awfully like a duplicate, can you please verify this?

Comment 20 Need Real Name 2008-09-19 22:36:14 UTC
I can't verify this due to bug 462483 - I have an unbootable box.

Comment 21 Peter Hutterer 2008-09-22 03:35:01 UTC
ok, just let us know when you can test again.
I'll leave the NEEDINFO flag so we get reminded later to re-visit the bug.

Comment 22 Need Real Name 2008-10-05 10:32:23 UTC
WFM now. Thanks.


Note You need to log in before you can comment on or make changes to this bug.