This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 447252 - Keyboard switcher does not work after bootup and incorrect layout set.
Keyboard switcher does not work after bootup and incorrect layout set.
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
9
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
: 440517 449305 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-19 01:40 EDT by Ilya
Modified: 2008-09-18 13:17 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-16 19:27:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshot showing the bug (62.69 KB, image/png)
2008-05-19 01:40 EDT, Ilya
no flags Details

  None (edit)
Description Ilya 2008-05-19 01:40:03 EDT
Description of problem:

A keyboard layout bug. After boot strange characters entered from keyboard
instead proper ones. Also keyboard layout cannot be switched neither by
switchkey, nor through menu switcher. Default layout is US English, second
layout is Russian-winkeys. The proper layout can only be restored through
keyboard properties screen.

The attachment shows incorrect characters displayed just after bootup, with
layout indicator shows US English as the current layout.
Comment 1 Ilya 2008-05-19 01:40:03 EDT
Created attachment 305899 [details]
screenshot showing the bug
Comment 2 Ilya 2008-05-19 02:15:07 EDT
By the way, on the fresh system all worked well (FC9-release). The bug appeared
after I made updates from the Internet.
Comment 3 Milan Kerslager 2008-07-03 13:14:31 EDT
*** Bug 449305 has been marked as a duplicate of this bug. ***
Comment 4 Milan Kerslager 2008-07-03 13:21:44 EDT
I'm not sure what component should be selected for this bug. I hit the same
problem. After a restart I have to go to the keyboard setting through keyboard
applet and change something (deleting and adding keymap). Then keyboard
switching works then again. I'm using default GNOME session.
Comment 5 Ilya 2008-07-03 18:14:33 EDT
I think official Fedora notes should mention that languages other than English 
are not fully supported. Otherwise all people who use another language would 
think Fedora is a very buggy system.
Comment 6 Simos Xenitellis 2008-07-24 05:31:20 EDT
This bug appears to be similar to 

keyboard layout switching shortcut doesn't work after reboot
https://bugs.launchpad.net/bugs/196277

Could you please verify that you have enabled autologin on your system?

If this is the case, then it would be better to change the report title to
"Autologin in GNOME disables keyboard layout switching"
Comment 7 Alexey Kuznetsov 2008-07-24 05:40:00 EDT
As i know fedora 9 do not have autologin feature because xserver.1.4.9 do not
support it anymore.
Comment 8 Ilya 2008-07-24 06:01:30 EDT
You're wrong. It has no GUI for autologin to switch on, but I enabled autologin 
through config files.
Comment 9 Simos Xenitellis 2008-07-24 07:36:56 EDT
I am not familiar with Fedora; in Ubuntu there is an option in
System/Administration/Login Window/Security/Enable Automatic Login.

What this actually does is it tells GDM to let a specific user in by default.
Essentially, it's a GDM option in Ubuntu.
Comment 10 Peter Hutterer 2008-07-29 01:03:29 EDT
There are two separate issues here (from what I can tell so far).

One is that the keymap with autologin is different before and after the first
key has been pressed (when the keyboard is evdev anyway).

The other one is that gnome is incapable of setting the xkb map correctly.
Specifying layouts in HAL's fdi file or the xorg.conf works fine, including the
switcher applet.

I'm still trying to figure out why the second happens.
Comment 11 Peter Hutterer 2008-08-01 02:27:51 EDT
The fix is rather invasive [1]. I made F9 and rawhide packages, if you could
give them a try that would be much appreciated. Please make sure that you can
rollback in case something breaks:

F9 packages are at http://koji.fedoraproject.org/scratch/whot/task_751549/
Rawhide: http://koji.fedoraproject.org/scratch/whot/task_751591/

[1] http://people.freedesktop.org/~whot/patches/xkbfix/
Comment 12 Peter Hutterer 2008-08-05 02:42:02 EDT
This problem should be fixed in rawhide with 906-5. Can you please verify this.
Comment 13 Peter Hutterer 2008-08-07 03:09:08 EDT
*** Bug 440517 has been marked as a duplicate of this bug. ***
Comment 14 Nickolay V. Shmyrev 2008-08-25 17:37:53 EDT
Can you please update F9 packages, this bug is really critical. You have to go to the keyboard settings after every login and set layout switching again and again.
Comment 15 Peter Hutterer 2008-09-15 00:11:08 EDT
xorg-x11-server-Xorg 1.5.0 has been pushed to testing. This update should fix the issues with the keyboard switcher. Can you please verify this?

https://admin.fedoraproject.org/updates/F9/FEDORA-2008-8032
Comment 16 Fedora Update System 2008-09-16 19:26:51 EDT
xorg-x11-server-1.5.0-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Milan Kerslager 2008-09-18 13:17:18 EDT
The bug has been resoved with prior fixes as I'm using xorg-x11-server-Xorg-1.4.99.906-5.fc10.i386 now and I'm fine for some time at most machines. Even that I have problem with   produced by space key but only on one machine I have around with the same setup. See bud #460545 for more info.

Note You need to log in before you can comment on or make changes to this bug.