Bug 44108 - Initscripts call setsysfont with disregard for text mode
Summary: Initscripts call setsysfont with disregard for text mode
Status: CLOSED DUPLICATE of bug 26901
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-11 13:34 UTC by Mike A. Harris
Modified: 2014-03-17 02:21 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-11 13:34:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike A. Harris 2001-06-11 13:34:27 UTC
Description of Problem:  During boot time, the initscripts call the
program "setsysfont" which automatically loads an 8x16 font.  This
totally overrides the "vga=ext" or vga=whatver setting a user may have
put in lilo.conf.  The 80x50 text mode of the kernel requires an 8x8 or 
8x9 font for correct operation.


How Reproducible: 100% after new installation


Steps to Reproduce:
1. Edit lilo.conf, in global section add "vga=ext" then save and exit
2. Run lilo so the above change takes effect.
3. Reboot

Actual Results:

When the system comes up it starts out in 80x50 mode until the rc script
calls setsysfont, which then changes the font to an 8x16 font which
forces 80x25 mode upon you.

Expected Results:

Having the font left alone unmodified unless configured to use a
different font.  Having the video mode left in 80x50 mode, or 
whatever the kernel defaulted to either built in or specified 
in lilo.conf.

Additional Information:

As a temporary workaround, I have disabled setsysfont with:
chmod a-x /sbin/setsysfont

The correct behaviour then occurs of 80x50 mode working properly.
I haven't looked at the scripts, but it is likely just some bad
assumption there that needs to take into account other text mode
sizes.

Comment 1 Bill Nottingham 2001-06-11 14:40:21 UTC
This isn't fixable. You're free to change the default font to something more
that fits better on your preferred screen size.

*** This bug has been marked as a duplicate of 26901 ***


Note You need to log in before you can comment on or make changes to this bug.