Bug 44112 - RFE:Please add new modeline 1152x864@85 Hz
RFE:Please add new modeline 1152x864@85 Hz
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
: FutureFeature
: 44113 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-11 11:27 EDT by Bruce Bigby
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-11 22:11:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bruce Bigby 2001-06-11 11:27:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; SunOS 5.8 sun4u)

Description of problem:
For as long as I can remember, XFree86 has not supported the resolution
1152x864 @ an 85 Hz refresh rate.  I prefer the resolution, because it the
most optimal resolution for me -- the highest refresh rate at a reasonably
high resolution. 

I currently use 1280x1024 but the refresh rate is only 76 Hz.  My eyes
don't like to stare at 76 Hz for too long.  I need a minimum of 85 Hz. 
This is why I need the mode lines for 1152 x 864 @ 85 Hz.  Metro-X supports
the Mac resolution  -- 1152 x 864 @ 85 Hz.  I have the Metro-X server but
I'm trying to get away from this proprietary server.  The Metro-X server is
pretty good, but it has an annoying, but minor, bug.  Sometimes, I see
artifacts on the screen as a result of not redrawing some areas of the
screen properly -- for example, white lines in a black xterm that shouldn't
appear.  Anyway, I hope that you can support 1152 x 864 @ 85 Hz.  I don't
plan on buying a new monitor that can support 1280 x 1024 @ Hhz any time
soon.

I don't know whether you need this information, but here it goes:  I have
an ATI All In Wonder Pro 3D (Uses Mach 64 Server) and a 20" Sony Trinitron.

How reproducible:
Always

Steps to Reproduce:
1. Try to configure XFree for the 1152 x 864 @ 85 Hz resolution.	

Actual Results:  1152 x 864 @ 85 Hz not an option.  By  the way, the
Metro-X server supports this resolution.  I have the Metro-X 4.x
configuration file but I don't know how this translates to the XFree86
configuration file.

Expected Results:  I should be able to choose the 1152 x 864 @ 85 Hz
option.  I know that this proble seems minor, because there is a workaround
but I have to take my eyes seriously.  The only other alternative is 1024 x
768 @ 85 Hz, but I lose precious real estate.   I know that my monitor/card
can support 1152 x 864 @ 85 Hz and I've done it with the Metro-X server for
Linux glibc.  I'd like the same resolution under XFree86. This is one of
the reasons that I dropped XFree86 in favor of Metro-X.  However, XFree86
has come a long way with X 4.x and I'd like to start using it, since it
supports DRI, etc. 

Additional info:
Comment 1 David Lawrence 2001-06-11 11:37:11 EDT
*** Bug 44113 has been marked as a duplicate of this bug. ***
Comment 2 Mike A. Harris 2001-06-11 21:57:50 EDT
I'm more than happy to add the modeline for 1152x864@85 Hz, if you can
supply it to me.  Just attach it from your config file to the bug report
if you like, and I'll submit it to XFree86.  If there are other modes
you'd like to see added as well, please attach them all at once.

Thanks,
TTYL
Comment 3 Bruce Bigby 2001-06-11 22:11:10 EDT
I found the following mode line in the XMetroconfig file:

ModeLine   "1152x864" 121.5 1152 1216 1344 1568  864  865  868  911 +hsync -vsync

I'm not sure of how it translates to the XF86Config file
Comment 4 Mike A. Harris 2001-06-21 09:28:22 EDT
Mode added to 4.1.0.  Will appear in final release.

Note You need to log in before you can comment on or make changes to this bug.