Bug 441156 - system-config-network crash
system-config-network crash
Status: CLOSED DUPLICATE of bug 440462
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
8
i386 Linux
low Severity high
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-06 17:47 EDT by Adel ESSAFI
Modified: 2008-04-07 09:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-07 09:57:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adel ESSAFI 2008-04-06 17:47:33 EDT
When I open system-config-network, it crashes and report this log


Component: system-config-network
Version: 1.4.7
Summary: TB31c4e20f NCHardwareList.py:798:load:ValueError: invalid literal for
int() with base 10: 'None'

Traceback (most recent call last):
  File "/usr/sbin/system-config-network-gui", line 166, in runit
    window = mainDialog()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line
253, in __init__
    self.load()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line
278, in load
    self.loadHardware()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line
290, in loadHardware
    hardwarelist = getHardwareList()
  File "/usr/share/system-config-network/netconfpkg/NCHardwareList.py", line
890, in getHardwareList
    __HWList.load()
  File "/usr/share/system-config-network/netconfpkg/NCHardwareList.py", line
798, in load
    hw.Modem.BaudRate = int(wvdial[dev]['Baud'])
ValueError: invalid literal for int() with base 10: 'None'

Local variables in innermost frame:
hwconf: <netconfpkg.NCHardwareList.ConfHWConf instance at 0x9fb26ec>
i: 3
self: HardwareList.Ethernet.eth0.Status=ok
HardwareList.Ethernet.eth0.Name=eth0
HardwareList.Ethernet.eth0.Type=Ethernet
HardwareList.Ethernet.eth0.Card.ModuleName=tg3
HardwareList.Ethernet.eth0.Description=Broadcom Corporation NetXtreme BCM5755M
Gigabit Ethernet PCI Express
HardwareList.Wireless.wlan0.Status=ok
HardwareList.Wireless.wlan0.Name=wlan0
HardwareList.Wireless.wlan0.Type=Wireless
HardwareList.Wireless.wlan0.Card.ModuleName=iwl3945
HardwareList.Wireless.wlan0.Description=Intel Corporation PRO/Wireless 3945ABG
Network Connection
HardwareList.Ethernet.eth1.Status=configuré
HardwareList.Ethernet.eth1.Name=eth1
HardwareList.Ethernet.eth1.Type=Ethernet
HardwareList.Ethernet.eth1.Card.ModuleName=cdc_ether
HardwareList.Ethernet.eth1.Description=cdc_ether
HardwareList.Modem.Modem0.Status=configuré
HardwareList.Modem.Modem0.Name=Modem0
HardwareList.Modem.Modem0.Modem.DeviceName=/dev/modem
HardwareList.Modem.Modem0.Type=Modem
HardwareList.Modem.Modem0.Description=Generic Modem

isdncard: <netconfpkg.NCisdnhardware.ConfISDN instance at 0x9fd872c>
hw: Hardware.Status=configuré
Hardware.Name=Modem0
Hardware.Modem.DeviceName=/dev/modem
Hardware.Type=Modem
Hardware.Description=Generic Modem

dev: Modem0
wvdial: <netconfpkg.conf.ConfSMB.ConfSMB instance at 0xa171b8c>
Comment 1 Harald Hoyer 2008-04-07 09:57:39 EDT

*** This bug has been marked as a duplicate of 440462 ***

Note You need to log in before you can comment on or make changes to this bug.