Bug 44117 - tmpwatch trying to clean nonexistent /var/cache/man/X11R6/cat?
Summary: tmpwatch trying to clean nonexistent /var/cache/man/X11R6/cat?
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: tmpwatch   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
: 47859 49262 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-11 16:10 UTC by Jonathan Kamens
Modified: 2007-04-18 16:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-11 16:10:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jonathan Kamens 2001-06-11 16:10:48 UTC
The message below sums up the problem:

  Date: Sun, 10 Jun 2001 04:06:39 -0400
  From: root@kamens.brookline.ma.us (Cron Daemon)
  To: root@kamens.brookline.ma.us
  Subject: Cron <root@jik> run-parts /etc/cron.daily

  /etc/cron.daily/tmpwatch:

  error: lstat() of directory /var/cache/man/X11R6/cat? failed: No such
file or directory

I'm using tmpwatch-2.7.2-1.  Something like this might be in order, instead
of what's at the end of /etc/cron.daily/tmpwatch now:

  for d in /var/{cache/man,catman}/{X11R6/cat?,cat?,local/cat?}; do
      [ -d $d ] && /usr/sbin/tmpwatch -f $d
  done

Comment 1 Preston Brown 2001-07-02 18:21:04 UTC
changed in 2.7.3 and later.


Comment 2 Jonathan Kamens 2001-07-09 19:28:36 UTC
*** Bug 47784 has been marked as a duplicate of this bug. ***

Comment 3 Arenas Belon, Carlo Marcelo 2001-07-16 03:33:16 UTC
*** Bug 47859 has been marked as a duplicate of this bug. ***

Comment 4 Arenas Belon, Carlo Marcelo 2001-07-16 03:34:36 UTC
*** Bug 47784 has been marked as a duplicate of this bug. ***

Comment 5 Arenas Belon, Carlo Marcelo 2001-07-16 05:24:58 UTC
please take a look to bug 47859, where i posted an IMHO interesting patch.

also, even if it is resolved on rawhide a formal errata could be needed to 
close all the different cross dependency bugs related to this same problem

Comment 6 David Thiede 2001-07-18 00:58:53 UTC
*** Bug 49262 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.