Bug 49262 - cron.daily/tmpwatch generates No such file messages
Summary: cron.daily/tmpwatch generates No such file messages
Status: CLOSED DUPLICATE of bug 44117
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tmpwatch   
(Show other bugs)
Version: 7.1
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Preston Brown
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-17 15:07 UTC by David Thiede
Modified: 2007-04-18 16:34 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-17 20:24:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Thiede 2001-07-17 15:07:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010701

Description of problem:
cron.daily/tmpwatch generates error messages when attemping scan
directories that are non-existant when X sub-systems are not installed. The
install was based on the standard server install but with no X server
components. The message follows:
Subject: Cron <root@nsA> run-parts /etc/cron.daily

/etc/cron.daily/tmpwatch:

error: lstat() of directory /var/cache/man/X11R6/cat? failed: No such file
or directory

The X11R6 and local directories don't exist in /var/cache/man for our
installation. I would recommend expanding the conditional checks that are
used in /etc/cron.daily/tmpwatch that check for /var/cache/man to include
checks for the  sub-directories for situations where they don't exist.

How reproducible:
Always

Steps to Reproduce:
1. install without X packages
2. Configure sendmail
3. 
	

Actual Results:  cron sends a daily nag messages complaining about "No such
file or directory"

Expected Results:  Would like to not see the message.

Additional info:

Comment 1 Michael Schwendt 2001-07-17 20:22:21 UTC
Run this:

$ rpm -q man 
man-1.5i2-0.7x

and if you get the same output, this is a duplicate of bug #47859.

Comment 2 Michael Schwendt 2001-07-17 20:24:06 UTC
And also a duplicate of #44117 which seems to be the first one.

Comment 3 David Thiede 2001-07-18 00:58:57 UTC
This is truly a duplicate of some other bugs reported in the last week. Just
didn't see them when searching.

*** This bug has been marked as a duplicate of 44117 ***


Note You need to log in before you can comment on or make changes to this bug.