Bug 441313 - [RFE] Set BootManager=None in /etc/kde/kdm/kdmrc
[RFE] Set BootManager=None in /etc/kde/kdm/kdmrc
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kde-settings (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-07 10:36 EDT by Sebastian Vahl
Modified: 2008-04-10 08:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-10 08:56:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sebastian Vahl 2008-04-07 10:36:52 EDT
Description of problem:
In KDE 3.5.9 (or up to kde-settings-3.5-38) the entry for "BootManager" is not 
set. With KDE4 it is set to "BootManager=grub". So if you want to reboot from 
KDM directly you have to choose which grub entry should be used after the next 
boot.
IMHO this is a little bit confusing, at least if you update your system "in 
the normal way". So there will always be two kernels listed (and maybe 
the "Other" entry for Windows). But a normal user will maybe expect that a hit 
on "Reboot" just reboot his machine


Version-Release number of selected component (if applicable):
kde-settings-kdm-4.0-15

How reproducible:
ever

Steps to Reproduce:
1. Make sure that there is more than one entry in /etc/grub.conf
2. Start kdm
3. Hit reboot
  
Actual results:
You have to choose one entry to actually reboot.

Expected results:
The machine just reboot.
Comment 1 Kevin Kofler 2008-04-07 10:50:47 EDT
This is also reported to cause issues with SELinux, though I can't find the bug 
report anymore.
Comment 2 Rex Dieter 2008-04-07 10:56:25 EDT
I'm against changing this (I added BootManager=grub on purpose).  :)

You'll only see reboot options if you press-n-hold reboot button.  Simply
clicking reboot will reboot into grub's default choice.
Comment 3 Sebastian Vahl 2008-04-07 11:12:01 EDT
(In reply to comment #2)
> You'll only see reboot options if you press-n-hold reboot button.  Simply
> clicking reboot will reboot into grub's default choice.

This behaviour is not working with KDE4's KDM anymore (at least for me/my 
mouse) . Now I have to select an entry everytime. A short single click doesn't 
work.

Comment 4 Rex Dieter 2008-04-07 11:30:44 EDT
worksforme.  Wait, I see the opposite, I don't see any list of options on
press-n-hold anymore. ??
Comment 5 Kevin Kofler 2008-04-08 12:38:35 EDT
See also: https://bugzilla.redhat.com/show_bug.cgi?id=374011 for the SELinux 
trouble.
Comment 6 Rex Dieter 2008-04-08 20:14:59 EDT
confirmed ok here with selinux=enforcing.

But, due to selinux policy (bug #373011), BootManager=grub doesn't work, so I
guess there's no point in trying to use it.
Comment 7 Rex Dieter 2008-04-10 08:56:20 EDT
fixed in rawhide

* Thu Apr 10 2008 Rex Dieter <rdieter@fedoraproject.org> 4.0-18
...
- kdmrc: [Shutdown] BootManager=None (#441313)

Note You need to log in before you can comment on or make changes to this bug.