Bug 441436 - cannot install Fedora 8 or Fedora 9 trees
cannot install Fedora 8 or Fedora 9 trees
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-manager (Show other bugs)
All Linux
low Severity low
: rc
: ---
Assigned To: Daniel Berrange
Virtualization Bugs
Depends On: 441788
  Show dependency treegraph
Reported: 2008-04-07 23:53 EDT by Jens Petersen
Modified: 2009-12-14 16:16 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-05-02 05:29:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2008-04-07 23:53:41 EDT
Description of problem:
I tried installing Fedora 8 and Fedora 9 under Xen with RHEL 5.2 Beta
but was not able too.  It seems virt-manager does not recognize
recent Fedora release trees as proper trees.  Maybe because of
changes/renaming of Fedora/ to Packages/?

It would be nice to be able to test and run the new Fedora 9 kernel-xen.
Comment 1 Cole Robinson 2008-04-08 13:27:58 EDT
Can you list what versions of virt-manager and python-virtinst you are using?
I'm pretty sure this should be fixed in the latest python-virtinst (0.300.2-8.el5).

I've tested this version with f9 and it works, but if you could also confirm I'd
appreciate it.
Comment 2 Jens Petersen 2008-04-11 01:34:01 EDT
I think this is the same as bug 441788 I reported for F9.
I tried again with the latest rawhide and got the same with
python-virtinst-0.300.3-5.fc9 and virt-manager-0.5.4-3.fc9.

Perhaps I am missing something or doing something wrong?
Comment 3 Cole Robinson 2008-04-11 10:48:49 EDT
Hmm. So  I assume you are trying PV installs on the rhel5 host? Can you post
~/.virt-manager/virt-manager.log after trying both an f8 and an f9 install? Also
can you describe exactly where it errors?

My packages are:
# rpm -qa | grep virt

And I can't reproduce this for an F8 guest. Rawhide using
http://fedora.zero42.at/linux/development/x86_64/os/ also works fine and makes
it to the install prompt.
Comment 4 Jens Petersen 2008-04-14 23:22:37 EDT
I am afraid I don't normally use RHEL5 but was testing for a colleague here
who does - let me provide more detailed info once I have managed to get it working
under F9/rawhide, which is now at 0.5.4.

> Rawhide using [..] also works fine and makes it to the install prompt.

Yes I think I get to stage1 too, but the problem I see is not reaching stage2 AFAICR
(and the same thing under rawhide).
Comment 5 Cole Robinson 2008-04-15 10:11:54 EDT
hmm. If you can get to stage1, after that point it is pretty much out of
virt-managers hands. So if you can't pull down stage2, my guess is that the
guest networking wasn't doing its job and couldn't pull down stage2. I just made
it to stage2 on rhel5 installing a rawhide guest. Regardless, post your results
when you get setup and hopefully we can track down the culprit. Thanks.
Comment 6 Jens Petersen 2008-05-02 05:29:44 EDT
Ok I tried again now a bit harder and managed to install current rawhide
with both paravirt and fullvirt.

I did get a python backtrace once but basically it is working for me now.
Comment 7 Jens Petersen 2008-05-02 05:44:23 EDT
(In reply to comment #6)
> Ok I tried again now a bit harder and managed to install current rawhide
> with both paravirt and fullvirt.

Errm, well at least PV. ;)

Wouldn't it make sense to disable FV in virt-manager installer if it is not
Comment 8 Daniel Berrange 2008-05-02 09:10:45 EDT
virt-manager *does* disable the FV option if the host OS does not support it. If
this is not working please file a *separate* bug report. 1 bug report per ticket

Note You need to log in before you can comment on or make changes to this bug.