Bug 441470 - mk-images failed on ia64
mk-images failed on ia64
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
ia64 Linux
low Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2008-04-08 06:21 EDT by Zhan, Yi
Modified: 2008-06-21 16:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-21 16:18:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix mk-images issue on ia64 (813 bytes, patch)
2008-04-08 06:21 EDT, Zhan, Yi
no flags Details | Diff
set KERNELDIR variable appropriately on ia64 (396 bytes, patch)
2008-04-09 04:39 EDT, Zhan, Yi
no flags Details | Diff

  None (edit)
Description Zhan, Yi 2008-04-08 06:21:41 EDT
Description of problem:

pungi failed on ia64's koji for several days. The cause is below 2 lines in
mk-images: 

    vmlinuz=$(rpm --nodigest --nosignature -qpl $kpackage |grep ^/boot/vmlinuz |
head -n 1)
    version=${vmlinuz##/boot/vmlinuz-}

These could not work on ia64. Since the directory which hold vmlinuz on ia64 is
/boot/efi/EFI/redhat/, not /boot/. A rough fix is attached. 

Version-Release number of selected component (if applicable):
anaconda-runtime-11.4.0.66-1.ia64.rpm

How reproducible:
always

Steps to Reproduce:
1.run pungi on ia64 using anaconda-runtime-11.4.0.66-1.ia64.rpm
2.
3.
  
Actual results:

/tmp/updboot.kernel.15582/ia64/lib/modules/2.6.25-0.201.rc8.git4.fc9 is not a
valid modules directory

The full log is available at
http://ia64.koji.fedoraproject.org/fedora-ia64/rawhide-20080408/logs/ia64.log 


Expected results:


Additional info:
Comment 1 Zhan, Yi 2008-04-08 06:21:41 EDT
Created attachment 301617 [details]
fix mk-images issue on ia64
Comment 2 Jeremy Katz 2008-04-08 08:22:08 EDT
Committed; ew'll be building anaconda later today
Comment 3 Zhan, Yi 2008-04-09 04:39:33 EDT
Created attachment 301762 [details]
set KERNELDIR variable appropriately on ia64
Comment 4 Zhan, Yi 2008-04-09 04:40:45 EDT
Thanks for the quick modification!

Er, haven't got time to do a test build yesterday. So a similar issue was
omitted in the previous fix. The KERNELDIR is set to /boot, it should be
/boot/efi/EFI/redhat on IA64 as well. 

A test build has done, pungi works fine with this additional fix. 
Comment 5 Doug Chapman 2008-04-09 12:15:55 EDT
Since this BZ is closed I have filed bug 441708 for the KERNELDIR issue.
Comment 6 Bug Zapper 2008-05-14 05:07:53 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.