Bug 441521 - Starting wine freezes X the desktop
Starting wine freezes X the desktop
Status: CLOSED DUPLICATE of bug 443552
Product: Fedora
Classification: Fedora
Component: wine (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-04-08 11:39 EDT by Igor Bukanov
Modified: 2008-06-12 04:47 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-06-11 12:52:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
system.reg that causes the system freeze (333.21 KB, text/plain)
2008-04-08 13:41 EDT, Igor Bukanov
no flags Details
minimal crashing system.reg (21.19 KB, application/octet-stream)
2008-04-08 14:44 EDT, Igor Bukanov
no flags Details

  None (edit)
Description Igor Bukanov 2008-04-08 11:39:34 EDT
Description of problem:

The system freezes when I run from gnome-terminal 

wine notepad.exe 

With the freeze Ctrl-Alt-Backspace does not work and I can not use Ctrl-Alt-Fn
to switch to a virtual console.

Version-Release number of selected component (if applicable):

This is with rawhide with all updates as of 2008-04-08 12:00 UTC. I run rawhide
installed on my Dell Latitude-X1 notebook with 1.1GHz CPU and 1128MB RAM.

How reproducible:

Install wine with rawhide and run wine notepad.exe.
Comment 1 Andreas Bierfert 2008-04-08 12:11:38 EDT
Could you please add more information based on the reporting bug part of
Comment 2 Igor Bukanov 2008-04-08 13:02:01 EDT
More info:

wine version: 0.9.58
Selinux mode: enforcing
Window manager: gnome-session with metacity
wine subpackages:


wine works fine with fresh ~/.wine. With ~/.wine that I used in F8 it freezes
the system. This is hard freeze as I cannot ping the system and the following
script that I run in the background:

while true; do
    sleep 1
    date +%T >> $HOME/log.txt

after the reboot shows the time of the crash in ~/log.txt. Also after the crash
there is no disk activity as shown by a notebook indicator. 

So it looks like a kernel bug. Should I change the component? I can also can try
to attach .wine after removing a windows application installed there. 
Comment 3 Igor Bukanov 2008-04-08 13:41:32 EDT
Created attachment 301664 [details]
system.reg that causes the system freeze

The content of the attached .wine/system.reg causes the freeze. That is,

    rm -rf ~/.wine
    wine notepad.exe 

creates the default ~/.wine and runs notepad.exe normally. But replacing
.wine/system.reg with the attached file triggers the whole system freeze when
running "wine notepad.exe".
Comment 4 Igor Bukanov 2008-04-08 14:44:07 EDT
Created attachment 301687 [details]
minimal crashing system.reg

The attached system.reg contains single entry:

[System\\CurrentControlSet\\Services\\Spooler] 1181644148
"Description"="Loads files to memory for later printing."
"DisplayName"="Print Spooler"

Using the file as ~/.wine/system.reg causes a total system freeze when running
"wine notepad.exe". The crash happens with a wireless networking enabled or
with networking disabled as set with NetworkManager.

Note that a default system.reg generated after 
  rm -rf ~/.wine; wine notepad.exe  

does not contain the entry.
Comment 5 Andreas Bierfert 2008-04-08 14:45:35 EDT
Thanks for the good bug report. I will see what I can do about this.
Comment 6 Igor Bukanov 2008-04-08 14:49:37 EDT
(In reply to comment #5)
> Thanks for the good bug report. I will see what I can do about this.

If necessary I can give an access to the notebook over ssh. 
Comment 7 Igor Bukanov 2008-04-08 14:55:40 EDT
(In reply to comment #4)
> The attached system.reg contains single entry:
> [System\\CurrentControlSet\\Services\\Spooler] 1181644148

Removing that entry from the original system.reg file also fixes the issue and
the Windows application runs normally.
Comment 8 Bug Zapper 2008-05-14 05:08:44 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
Comment 9 Michael Wiktowy 2008-05-14 18:29:02 EDT
In reply to Comment #4:

That is not true. A newly generated ~/.wine/system.reg does have that Spooler

The difference is that the newly generated functional one has a:
instead of the non-functional old:

Changing that single number (and doing a 'service wine restart' just for fun)
made my wine work again.

I think the wine devs went a little too far in emulating MSWindows behaviour
when a -2 can bring down the entire OS rather than just crash wine ;]
Comment 10 Benny 2008-06-02 03:56:25 EDT
Several people suffer from this bug, a bug was listed at wine:
But it was "closed invalid"
Quote: "Wine can't freeze your system, that's most likely a kernel driver bug."

Strangely enough this bug only occurs when wine preforms. Also, this bug occurs
on computers with different architectures, with complete different hardware...

Comment 11 Michael Wiktowy 2008-06-02 10:31:28 EDT
Can you add a reference to this Fedora bug number in that upstream bug?
It contains a specific triggering mechanism that might enable the developers to
reproduce it and narrow down what is at fault.
Comment 12 Benny 2008-06-02 15:10:54 EDT
I added the link to this bug in a comment at wine's Bugzilla, wine does not have
a upstream resolution.
Comment 13 Benny 2008-06-02 15:26:22 EDT
Does anyone know already if this is a kernel bug or a x11 bug?
Comment 14 Jeremy White 2008-06-04 11:06:45 EDT
Any way this can get a priority boost?

It's rather insulting to Wine folks that a bug in FC9 that causes
a system crash is rated as priority 'low', severity 'low'.

Wine runs completely in user space, so by definition, anything it does
that causes a system freeze is *not* a Wine bug.


Comment 15 Anastasius Focht 2008-06-06 19:20:41 EDT

same issue here: https://bugzilla.redhat.com/show_bug.cgi?id=443552 ... that one
has at least correct severity ;-)
I added some kernel oopsies with and wine-1.0-rc4 there.

Comment 16 Nicola Soranzo 2008-06-11 12:52:03 EDT

*** This bug has been marked as a duplicate of 443552 ***

Note You need to log in before you can comment on or make changes to this bug.