Bug 443552 - Kernel 2.6.25 + Wine = hang
Kernel 2.6.25 + Wine = hang
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
All Linux
low Severity urgent
: ---
: ---
Assigned To: Roland McGrath
Fedora Extras Quality Assurance
:
: 441521 450407 (view as bug list)
Depends On:
Blocks: 443860
  Show dependency treegraph
 
Reported: 2008-04-22 03:03 EDT by Artem
Modified: 2008-07-23 13:15 EDT (History)
19 users (show)

See Also:
Fixed In Version: 2.6.25.6-55.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-12 22:27:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
serial console capture of kernel bug (2.95 KB, text/plain)
2008-04-29 19:19 EDT, Jimmy Rentz
no flags Details
2.6.25 oops using wine 1.0 rc4 captured via serial console (6.92 KB, text/plain)
2008-06-06 19:04 EDT, Anastasius Focht
no flags Details

  None (edit)
Description Artem 2008-04-22 03:03:37 EDT
Description of problem:
System always freeze when I boot with rawhide kernel, 2.6.24-4.fc8 work fine

Version-Release number of selected component (if applicable):
kernel-2.6.25-1.fc9.x86_64

How reproducible:
Boot with 2.6.25 kernel

Steps to Reproduce:
1.Boot with 2.6.25 kernel
2.Wait for ~2 minutes after login (kde)

  
Actual results:
System freezes (no info in any log)


Additional info:
System is updated, not fresh installed.
Comment 1 Chuck Ebbert 2008-04-22 15:56:44 EDT
Please try the workarounds from:

http://fedoraproject.org/wiki/KernelCommonProblems

and report back on which ones (if any) help.
Comment 2 Artem 2008-04-25 03:41:31 EDT
Well, after some test I have found, that system hangs after I start any WINE
application (Lotus notes,MS Word)
Comment 3 Chuck Ebbert 2008-04-26 21:19:10 EDT
Does running this command as root before starting any WINE apps help?

  echo "0" >/proc/sys/vm/mmap_min_addr

Comment 4 Jimmy Rentz 2008-04-29 19:19:02 EDT
Created attachment 304165 [details]
serial console capture of kernel bug

Serial console dump.
NOTE: I couldn't get the magic sysrq to work.
Comment 5 Artem 2008-04-30 02:31:36 EDT
Unfortunately 
echo "0" >/proc/sys/vm/mmap_min_addr
doesn't help. Behaviour is the same.
Comment 6 Chuck Ebbert 2008-05-01 04:03:23 EDT
Utrace bug?

static inline void tracehook_release_task_locked(struct task_struct *p)
{
        int bad = 0;
====>   BUG_ON(p->exit_state != EXIT_DEAD);
        if (unlikely(tsk_utrace_struct(p) != NULL)) {
                /* 
                 * In a race condition, utrace_attach will temporarily set
                 * it, but then check p->exit_state and clear it.  It does
                 * all this under task_lock, so we take the lock to check
                 * that there is really a bug and not just that known race.
                 */
                task_lock(p);
                bad = unlikely(tsk_utrace_struct(p) != NULL);
                task_unlock(p);
        }
        BUG_ON(bad);
}
Comment 7 Roland McGrath 2008-05-01 17:37:23 EDT
I did just fix an upstream utrace bug with the same failure mode.
I'd like to verify the details of the scenario happening here, though.
Is there a way to reproduce this using only standard/free components?
I'm not familiar with details of using wine.  Is there a simple recipe to
reproduce this crash using test apps that come in wine rpms?
Comment 8 Jimmy Rentz 2008-05-01 18:51:40 EDT
I got the dump above by just running the winecfg (Wine Configuration Tool in
gnome/system tools).  It locks up pretty quick.
Comment 9 Bug Zapper 2008-05-14 05:55:09 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 cornel panceac 2008-05-18 11:31:29 EDT
is happening indeed in f9 updated, while starting ie6. same behaviour on
multiple systems, limiting the number of processes to 2000 per user in
limits.conf doesn't help.

$ rpm -q wine
wine-0.9.58-1.fc9.i386

$ uname -r
2.6.25.3-18.fc9.i686
Comment 11 Adam Goode 2008-06-01 13:15:17 EDT
I am getting a hang when I try to use ies4linux to install ie6 and ie7.

~/ies4linux-2.99.0.1 $ ./ies4linux --no-flash --beta-install-ie7 --no-gui
--no-desktop-icon

It runs for a while, then hard locks the machine. (Audio playing at that time
starts to loop.)

This is on P4 x86_64.

kernel-2.6.25.3-18.fc9.x86_64
wine-0.9.58-1.fc9.i386
Comment 12 Anastasius Focht 2008-06-06 19:04:23 EDT
Created attachment 308578 [details]
2.6.25 oops using wine 1.0 rc4 captured via serial console

Hello,

any updates on this bug?

2.6.25.4-30.fc9.i686 + wine-1.0-rc4 = no change (tested on different machines).

Plenty of freezes which makes Fedora 9 completely unusable for running wine.

Attached is collection of 3 kernel oops (similar to comment #4).
Note: same happens with untainted kernel (nvidia driver removed)

Regards
Comment 13 Ilya 2008-06-08 07:27:48 EDT
Civilization I for Windows also stucks.

The game shows splash screen and plays intro music, but does not react on mouse
clicks (normally mouse click should skip intro). After music is over, the game
simply stucks with its splash screen window still displayed.

The game run well under Wine 1.0-rc1 and earlier versions of Wine (although
with some minor bugs), so this is a post-rc1 regression.

The attachment shows console output.
Comment 14 Ilya 2008-06-08 07:28:47 EDT
Here is the error message:

wine: Unhandled page fault on read access to 0x0000000c at address 0x605ad6ae
(thread 0019), starting debugger...
Unhandled exception: page fault on read access to 0x0000000c in 32-bit code
(0x605ad6ae).
Comment 15 Ilya 2008-06-08 07:29:30 EDT
Wine version is 1.0-rc4.
Comment 16 Ilya 2008-06-08 07:31:57 EDT
Under Ubuntu 8.04 the same Wine version works well. It should be added that 
before system updates it also worked in FC9.
Comment 17 Christian Krause 2008-06-08 14:16:19 EDT
I've seen the same problem on my system, too:
kernel-2.6.25.4-30.fc9.i686
wine-0.9.58-1.fc9.i386

Just starting "wine winhelp.exe" triggers the kernel crash.

The backtrace of the kernel varies each time a little bit, but the last calls
are always: get_signal_to_deliver, do_group_exit and do_exit.
I can also reproduce this without having X running in single user mode (as
regular user).

I'll associate the appropriate wine bug, which also contains a screenshot of the
backtrace: https://bugzilla.redhat.com/attachment.cgi?id=308645 .

If necessary, I can also provide a screenshot of this crash on my system.

I'd like to second comment #9 of the associated wine bug, that if a user can
easily crash the kernel itself without any involved SetUID programs, then this
should be really be treated as a severe kernel bug.

Comment 18 Louis Lenders 2008-06-09 07:20:57 EDT
Hi, the troubles reported for  wine+fedora 9, now also affect fedora 8. 

Last saturday i did a 'yum update', and after that about all wine-applications
froze my computer. Only a hard reboot helped...

I'd suggest to remove kernel-update from the fedora-8 update-packages , or
something the like. 
 
Comment 19 Anastasius Focht 2008-06-09 20:04:19 EDT
Things will probably escalate further if more wine users update their previously
working Fedora 8 kernels using yum.
Mark any F8/F9 bug report in wine bugzilla which mentions "freeze" or "hard
lock" as INVALID and keep on redirecting people here ;-)

Though not really feasible for the average user, my current workaround is to
rebuild 2.6.25.* kernels without that utrace patch applied (linux-2.6-utrace.patch).
That works (tm).

Regards
Comment 20 Roland McGrath 2008-06-10 04:43:57 EDT
*** Bug 450407 has been marked as a duplicate of this bug. ***
Comment 21 Anastasius Focht 2008-06-10 05:27:46 EDT
If there is any updated/proposed utrace patch available, I'm willing to help
testing...

Regards
Comment 22 Patrick Higgins 2008-06-10 11:38:10 EDT
I think I'm seeing this bug, too. I don't have a serial console so I'm not sure
if it's crashing in the same place, but I'm running FC9 with
2.6.25.4-30.fc9.i686 and wine-0.9.58-1 and can easily reproduce this by running
the setup program for Excel. I'd be happy to help test any patches.
Comment 23 Chuck Ebbert 2008-06-10 15:21:06 EDT
Should be fixed in 2.6.25.6-54 and later kernels.
Comment 24 Bryan Christ 2008-06-11 12:15:08 EDT
Chuck,

Can you place that kernel in updates-testing repo?
Comment 25 Nicola Soranzo 2008-06-11 12:52:04 EDT
*** Bug 441521 has been marked as a duplicate of this bug. ***
Comment 26 Nicola Soranzo 2008-06-11 13:01:52 EDT
(In reply to comment #24)
> Chuck,
> 
> Can you place that kernel in updates-testing repo?

You can download it form Koji:

http://koji.fedoraproject.org/koji/buildinfo?buildID=52276
Comment 27 Cory Bell 2008-06-11 14:37:03 EDT
I was having a similar issue - Crossover Office would hang the machine hard when
installing IE 6 SP1 (Oddly enough, Outlook 2003 worked fine - at least, as well
as it ever does). After installing 2.6.25.6-54, the hang went away. Thanks, Chuck!
Comment 28 Bryan Christ 2008-06-11 15:09:35 EDT
Fixed for me with kernel 2.6.25.6-55 from URL in comment 26.
Comment 29 Fedora Update System 2008-06-11 21:38:51 EDT
kernel-2.6.25.6-55.fc9 has been submitted as an update for Fedora 9
Comment 30 Fedora Update System 2008-06-12 22:26:49 EDT
kernel-2.6.25.6-55.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 31 Andrea Dell'Amico 2008-06-30 20:15:40 EDT
(In reply to comment #30)
> kernel-2.6.25.6-55.fc9 has been pushed to the Fedora 9 stable repository.  If
problems still persist, please make note of it in this bug report.

That kernel doesn't fix the problem for me. I have the same behaviour as the
past f9 kernels, each time I try to run World of Warcraft (it's the only windows
software I have).
Comment 32 Hin-Tak Leung 2008-06-30 20:34:41 EDT
I am running 2.6.25.9-76.fc9 and just ran ie4linux (IE6 on wine in a special
WINEPREFIX) and another app under wine and works alright. 
Comment 33 Andrea Dell'Amico 2008-07-01 18:15:39 EDT
Even 2.6.25.9-76.fc9 is regularly crashing. And my wireless connection doesnt'
work anymore (standard hardware, with no proprietary driver: wireless is intel
3945, graphics is intel 945GM).
Back to 2.6.25.6-55.fc9 :-).
Comment 34 Davide Repetto 2008-07-02 13:17:50 EDT
Here it all seems ok with 2.6.25.9-76.fc9 (i386 32 bit).
I have run quite a few windows apps with no problems.
Comment 35 Christian Krause 2008-07-03 04:53:45 EDT
(In reply to comment #28)
> Fixed for me with kernel 2.6.25.6-55 from URL in comment 26.

I'd like to seconds this comment. Since 2.6.25.6-55 wine doesn't crash the
kernel anymore and so the original problem is solved.
Comment 36 Nikita 2008-07-04 06:20:52 EDT
I had to install old 2.6.23 kernel, because all 2.6.25 kernels produces freeze
of my fedora8 with something running under wine
Comment 37 Nikita 2008-07-04 06:28:27 EDT
Was able to reproduce this bug yesterday with 2.6.25.9-40.fc8.i686 kernel. 
wine - 0.9.36
My system froze after several minutes of playing Warcraft III 
Works fine with 2.6.23 or 2.6.24 
Comment 38 Hin-Tak Leung 2008-07-04 07:05:47 EDT
The utrace fix when into fc8 a month ago:

* Mon Jun 09 2008 Chuck Ebbert <cebbert@redhat.com> 2.6.25.6-24
- Copy utrace and mmc driver bug fixes from F-9.

I don't use f8 any more, but surely one of two of any of these:
http://koji.fedoraproject.org/koji/buildinfo?buildID=52276
has gone into f8 updates?

Also, FWIW, wine 0.9.36 is really old - wine 1.0 is out, and even wine 1.1.0 is
out a week ago.
Comment 39 Andrea Dell'Amico 2008-07-04 08:11:23 EDT
Ok, is there a way I can debug without having a serial console? My machine is a
laptop without serial ports.

WoW keeps freezing the box, I'm using the latest packages for kernel and wine
and I also tried the X driver available in updates-testing.
Comment 40 Jan Kratochvil 2008-07-04 13:39:35 EDT
(In reply to comment #39)
> Ok, is there a way I can debug without having a serial console? My machine is a
> laptop without serial ports.

Check `service kdump' of kexec-tools, you need to configure its /etc/kdump.conf.
(While it works during artificial tests for me, it did not dump anything during
occasional real crashes for me, though.)
Comment 41 Andrea Dell'Amico 2008-07-07 19:34:36 EDT
(In reply to comment #40)

> Check `service kdump' of kexec-tools, you need to configure its /etc/kdump.conf.
> (While it works during artificial tests for me, it did not dump anything during
> occasional real crashes for me, though.)

Obviously now it doesn't crash anymore.
It crashed once, but no kdump output, and after that I've not been able to
reproduce the crash.


Note You need to log in before you can comment on or make changes to this bug.