Bug 441617 - doesn't work on most flash sites
doesn't work on most flash sites
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: swfdec-mozilla (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
:
: 441710 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-08 22:24 EDT by Bill Nottingham
Modified: 2014-03-16 23:13 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.6.4-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-10 19:10:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2008-04-08 22:24:33 EDT
Description of problem:

For example, bothe scoreboard and the linked gamecast at
mlb.com don't work correctly.

None of the flash entries on the front page of uefa.com work.

youtube does not work (movies are just a black screen, no sound,
even with the proper plugins.)

I'm hard-pressed to find a site where it works at all.

Version-Release number of selected component (if applicable):

swfdec-mozilla-0.6.0-1.fc9
How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Bill Nottingham 2008-04-08 22:34:06 EDT
http://www.gamedesign.jp/flash/tennis/tennis.html

causes the plugin to abort.

#0  0x0000003827432ef5 in raise (sig=<value optimized out>)
    at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#1  0x0000003827434a63 in abort () at abort.c:88
#2  0x0000003f77215523 in pa_operation_unref () from /usr/lib64/libpulse.so.0
#3  0x00000000008246dd in IA__g_closure_invoke (closure=0xed4cc0, return_value=0x0, 
    n_param_values=2, param_values=0x7fff28bfda60, invocation_hint=0x7fff28bfd960)
    at gclosure.c:490
#4  0x000000000083855c in signal_emit_unlocked_R (node=0xd5eac0, detail=0, 
    instance=0xe1c090, emission_return=0x0, instance_and_params=0x7fff28bfda60)
    at gsignal.c:2440
#5  0x00000000008399de in IA__g_signal_emit_valist (instance=0xe1c090, 
    signal_id=<value optimized out>, detail=0, var_args=0x7fff28bfdcc0)
    at gsignal.c:2199
#6  0x0000000000839d14 in IA__g_signal_emit_by_name (instance=0xe1c090, 
    detailed_signal=0x7fce2008fcf4 "audio-removed") at gsignal.c:2267
#7  0x00007fce2002a155 in swfdec_audio_remove (audio=0x1b215e0) at
swfdec_audio.c:120
#8  0x00007fce20053fe3 in swfdec_player_do_advance (player=0xe1c090, 
    msecs=<value optimized out>, audio_samples=1456) at swfdec_player.c:1443
#9  0x00000000008246dd in IA__g_closure_invoke (closure=0xd5dd00, return_value=0x0, 
    n_param_values=3, param_values=0x7fff28bfe0b0, invocation_hint=0x7fff28bfdfb0)
    at gclosure.c:490
#10 0x000000000083823d in signal_emit_unlocked_R (node=0xd5dd70, detail=0, 
    instance=0xe1c090, emission_return=0x0, instance_and_params=0x7fff28bfe0b0)
    at gsignal.c:2478
#11 0x00000000008399de in IA__g_signal_emit_valist (instance=0xe1c090, 
    signal_id=<value optimized out>, detail=0, var_args=0x7fff28bfe310)
    at gsignal.c:2199
#12 0x0000000000839f23 in IA__g_signal_emit (instance=0x661e, signal_id=26142,
detail=6)
    at gsignal.c:2243
#13 0x00007fce20050c17 in swfdec_player_advance (player=0xe1c090, msecs=33)
    at swfdec_player.c:2612
#14 0x00007fce202dbb28 in swfdec_iterate_dispatch (source_=0xed4c30, 
Comment 2 Bill Nottingham 2008-04-08 22:36:42 EDT
After some work, video can be made to work in youtube, but audio is still broken.
Comment 3 Bill Nottingham 2008-04-08 23:00:54 EDT
swfdec was using a bad gst plugin for audio. Offending plugin remove, and it
sort of works. However, the volume slider in youtube and similar places has no
effect.
Comment 4 Bill Nottingham 2008-04-08 23:02:24 EDT
... that also fixes the tennis game abort. So, we're up to two!
Comment 5 Bill Nottingham 2008-04-08 23:02:54 EDT
Whoops, spoke too soon. Still aborts occasionally on that site.
Comment 6 Bill Nottingham 2008-04-09 12:27:14 EDT
*** Bug 441710 has been marked as a duplicate of this bug. ***
Comment 7 Benjamin Otte 2008-04-10 16:50:16 EDT
This bug has been a communication problem. The PA backend is still considered
experimental, but was enabled because the ALSA backend did not work with Pulseaudio.

A fix for the ALSA backend is in upstream git.
Comment 8 Brian Pepple 2008-04-10 19:10:20 EDT
Pulled Benjamin's patch from git.

Note You need to log in before you can comment on or make changes to this bug.