Bug 441710 - PA aborts when called by swfdec
PA aborts when called by swfdec
Status: CLOSED DUPLICATE of bug 441617
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-09 12:23 EDT by Bill Nottingham
Modified: 2014-03-16 23:13 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-09 12:27:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2008-04-09 12:23:19 EDT
Description of problem:

http://www.gamedesign.jp/flash/tennis/tennis.html

is the example flash of the day. PA aborts the swfdec process.

(gdb) bt
#0  0x00000033d2232ef5 in raise (sig=<value optimized out>)
    at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#1  0x00000033d2234a63 in abort () at abort.c:88
#2  0x00000033dca15523 in pa_operation_unref (o=<value optimized out>)
    at pulse/operation.c:69
#3  0x00000033d5a0b6dd in IA__g_closure_invoke (closure=<value optimized out>, 
    return_value=<value optimized out>, n_param_values=<value optimized out>, 
    param_values=<value optimized out>, invocation_hint=<value optimized out>)
    at gclosure.c:490
#4  0x00000033d5a1f55c in signal_emit_unlocked_R (node=<value optimized out>, 
    detail=<value optimized out>, instance=<value optimized out>, 
    emission_return=<value optimized out>, instance_and_params=<value optimized
out>)
    at gsignal.c:2440
#5  0x00000033d5a209de in IA__g_signal_emit_valist (instance=<value optimized out>, 
    signal_id=<value optimized out>, detail=<value optimized out>, 
    var_args=<value optimized out>) at gsignal.c:2199
#6  0x00000033d5a20d14 in IA__g_signal_emit_by_name (instance=<value optimized
out>, 
    detailed_signal=<value optimized out>) at gsignal.c:2267
#7  0x0000000000a6c165 in swfdec_audio_remove (audio=0x28b29e0) at
swfdec_audio.c:120
#8  0x0000000000a6c989 in swfdec_audio_event_new_from_chunk (player=0x1b62050, 
    chunk=0x2541c90) at swfdec_audio_event.c:306
#9  0x0000000000aa503b in swfdec_sprite_movie_perform_one_action (
    movie=<value optimized out>, tag=<value optimized out>, buffer=0x1d29100, 
    skip_scripts=0, first_time=1) at swfdec_sprite_movie.c:350
#10 0x0000000000aa625b in swfdec_sprite_movie_goto (movie=0x27f20b0, 
    goto_frame=<value optimized out>) at swfdec_sprite_movie.c:574
#11 0x0000000000aa86cf in swfdec_sprite_movie_gotoAndStop (cx=0x1b62050, 
    object=0x27f20b0, argc=1, argv=0x2121820, rval=<value optimized out>)
    at swfdec_sprite_movie_as.c:474
#12 0x0000000000a552c2 in swfdec_as_context_run (context=0x1b62050)
    at swfdec_as_context.c:870
#13 0x0000000000a64638 in swfdec_as_object_run (object=0x27f2340, 
---Type <return> to continue, or q <return> to quit---
    script=<value optimized out>) at swfdec_as_object.c:1212
#14 0x0000000000a9461b in swfdec_player_perform_actions (player=0x1b62050)
    at swfdec_player.c:516
#15 0x0000000000a95df3 in swfdec_player_do_handle_mouse (player=0x1b62050, x=526, 
    y=518, button=-1) at swfdec_player.c:1339
#16 0x0000000000ac74c1 in swfdec_marshal_BOOLEAN__DOUBLE_DOUBLE_INT
(closure=0x1a400a0, 
    return_value=0x7fff3b343a60, n_param_values=<value optimized out>, 
    param_values=0x7fff3b343b20, invocation_hint=<value optimized out>, 
    marshal_data=0xa95af0) at swfdec_marshal.c:85
#17 0x00000033d5a0b6dd in IA__g_closure_invoke (closure=<value optimized out>, 
    return_value=<value optimized out>, n_param_values=<value optimized out>, 
    param_values=<value optimized out>, invocation_hint=<value optimized out>)
    at gclosure.c:490
#18 0x00000033d5a1f23d in signal_emit_unlocked_R (node=<value optimized out>, 
    detail=<value optimized out>, instance=<value optimized out>, 
    emission_return=<value optimized out>, instance_and_params=<value optimized
out>)
    at gsignal.c:2478
#19 0x00000033d5a2085d in IA__g_signal_emit_valist (instance=<value optimized out>, 
    signal_id=<value optimized out>, detail=<value optimized out>, 
    var_args=<value optimized out>) at gsignal.c:2209
#20 0x00000033d5a20f23 in IA__g_signal_emit (instance=<value optimized out>, 
    signal_id=<value optimized out>, detail=<value optimized out>) at gsignal.c:2243
#21 0x0000000000a9326a in swfdec_player_mouse_release (player=0x1b62050, x=526,
y=518, 
    button=4294967295) at swfdec_player.c:2466
#22 0x0000000000118e1e in swfmoz_player_mouse_release ()
   from /usr/lib64/mozilla/plugins/libswfdecmozilla.so
#23 0x0000000000116f21 in ?? () from /usr/lib64/mozilla/plugins/libswfdecmozilla.so
#24 0x00000033db25418b in gdk_event_apply_filters (xevent=Could not find the
frame base for "gdk_event_apply_filters".
) at gdkevents-x11.c:345
#25 0x00000033db25527a in gdk_event_translate (display=Could not find the frame
base for "gdk_event_translate".
) at gdkevents-x11.c:984
#26 0x00000033db257a16 in _gdk_events_queue (display=Could not find the frame
base for "_gdk_events_queue".
) at gdkevents-x11.c:2285
#27 0x00000033db257bec in gdk_event_dispatch (source=Could not find the frame
base for "gdk_event_dispatch".
) at gdkevents-x11.c:2345
#28 0x00000033d3a3740a in IA__g_main_context_dispatch (context=<value optimized
out>)
---Type <return> to continue, or q <return> to quit---
    at gmain.c:2009
#29 0x00000033d3a3ab10 in g_main_context_iterate (context=<value optimized out>, 
    block=<value optimized out>, dispatch=<value optimized out>, 
    self=<value optimized out>) at gmain.c:2642
#30 0x00000033d3a3afdd in IA__g_main_loop_run (loop=<value optimized out>)
    at gmain.c:2850
#31 0x00000033da784870 in IA__gtk_main () at gtkmain.c:1163
#32 0x00000000004082e5 in g_free () at gmem.c:187
#33 0x00000033d221e40a in __libc_start_main (main=<value optimized out>, 
    argc=<value optimized out>, ubp_av=<value optimized out>, 
    init=<value optimized out>, fini=<value optimized out>, 
    rtld_fini=<value optimized out>, stack_end=Could not find the frame base for
"__libc_start_main".
) at libc-start.c:220
#34 0x0000000000402929 in g_free () at gmem.c:187
#35 0x00007fff3b3446b8 in ?? ()
#36 0x000000000000001c in ?? ()
#37 0x0000000000000005 in ?? ()
#38 0x00007fff3b3456dc in ?? ()
#39 0x0000000000000000 in ?? ()
(gdb) 

Version-Release number of selected component (if applicable):

pulseaudio-0.9.10-1.fc9.x86_64
swfdec-0.6.4-1.fc9.x86_64
Comment 1 Bill Nottingham 2008-04-09 12:27:12 EDT
Never mind. swfdec bug.

*** This bug has been marked as a duplicate of 441617 ***

Note You need to log in before you can comment on or make changes to this bug.