Bug 441760 - system-config-display 1.0.51-9.fc9.noarch crashed
system-config-display 1.0.51-9.fc9.noarch crashed
Status: CLOSED DUPLICATE of bug 374581
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
i386 Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-04-09 16:59 EDT by Frantisek Hanzlik
Modified: 2008-04-11 15:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-04-11 15:02:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Frantisek Hanzlik 2008-04-09 16:59:48 EDT
Description of problem:
Running system-config-display-1.0.51-9.fc9.noarch (rawhide dated 9-Apr-08]
result i apps crash with error:

[hanzlik@franta ~]$ system-config-display
Traceback (most recent call last):
  File "/usr/share/system-config-display/xconf.py", line 378, in <module>
    dialog = xConfigDialog.XConfigDialog(hardware_state, xconfig,
  File "/usr/share/system-config-display/xConfigDialog.py", line 540, in __init__
  File "/usr/lib/python2.5/site-packages/rhpxl/xhwstate.py", line 386, in
    self.colordepth = availableDepth[-1]
IndexError: list index out of range

Version-Release number of selected component (if applicable):
system-config-display-1.0.51-9.fc9.noarch at i386

How reproducible:
always, no matter if run with pre-existing "/etc/X11/xorg.conf" or not,
and with "--reconfig" crashes too.

Steps to Reproduce:
1. Run system-config-display from menu or terminal
2. Immediately after entering root pwd apps crashed
Actual results:

Expected results:

Additional info:
Comment 1 Adam Jackson 2008-04-11 15:02:15 EDT

*** This bug has been marked as a duplicate of 374581 ***

Note You need to log in before you can comment on or make changes to this bug.