Bug 441869 - order of 'serial' and 'console' can cause a hang during boot on SC1435s
order of 'serial' and 'console' can cause a hang during boot on SC1435s
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: booty (Show other bugs)
5.2
All Linux
high Severity high
: rc
: ---
Assigned To: Peter Jones
:
Depends On:
Blocks: 441870
  Show dependency treegraph
 
Reported: 2008-04-10 12:30 EDT by Corey Marthaler
Modified: 2008-09-25 16:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-25 16:01:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix the order or "serial" and "console" (556 bytes, text/plain)
2008-04-10 12:32 EDT, Nate Straz
no flags Details

  None (edit)
Description Corey Marthaler 2008-04-10 12:30:38 EDT
Description of problem:
Every so often, I'd would notice my new SC1435s hang during boot up. I contacted
Dell and they told me to switch the order of my terminal line from 'serial
console' to 'console serial', and the caused the problem to go away.

Here's what the output looked like before the hang:

======= 
GRUB 
Loading stage2... 
Press space to continue. 
Press space to continue. 
Press space to continue. 
Press space to continue. 
=======
[HANG]

Version-Release number of selected component (if applicable):


How reproducible:
once or so every 3-5 reboots
Comment 1 Nate Straz 2008-04-10 12:32:16 EDT
Created attachment 302015 [details]
Patch to fix the order or "serial" and "console"
Comment 4 Chris Lumens 2008-08-18 11:26:21 EDT
Just curious here... why does the order of the 'serial' and 'console' commands matter?
Comment 5 Nate Straz 2008-08-18 11:36:05 EDT
Something about the order makes our systems hang some of the time.  Reversing the order makes rebooting more reliable.
Comment 6 Peter Jones 2008-09-25 15:35:30 EDT
This change means grub will default to the keyboard+monitor for console instead of serial if no key is pressed.  This is almost certainly not the correct solution, as this code is only invoked if you're using a serial console for installation.

More investigation needs to be done into what exactly is hanging and why, and that needs to be fixed instead of this change.
Comment 7 RHEL Product and Program Management 2008-09-25 16:01:06 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.