Bug 441886 - NM does not honor dhcp-client-identifier or append domain-name-servers in /etc/dhclient.conf
NM does not honor dhcp-client-identifier or append domain-name-servers in /et...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-10 13:25 EDT by Orion Poplawski
Modified: 2008-09-28 14:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-28 14:45:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2008-04-10 13:25:04 EDT
Description of problem:

Have the following /etc/dhclient.conf:

send dhcp-client-identifier "bona";
append domain-name " cora.nwra.com";
append domain-name-servers 65.44.101.180;

We use dhcp-client-identifier to get the same ip regardless of interface.  We
also append our name server in case of borked public DNS servers while roaming.

Howeever, dhcp-client-identifier does not seem to be sent - we get a different
IP than expected.  The domain-name appears to be appended, but not the
domain-name-servers.  Also seem to have the set of nameservers listed twice.

/etc/resolv.conf:
# generated by NetworkManager, do not edit!

domain cora.nwra.com

search cora.nwra.com cora.nwra.com

nameserver 192.168.0.8
nameserver 192.168.0.12
nameserver 192.168.0.8

# NOTE: the glibc resolver does not support more than 3 nameservers.
# The nameservers listed below may not be recognized.
nameserver 192.168.0.12

Version-Release number of selected component (if applicable):
NetworkManager-0.7.0-0.9.1.svn3521.fc9.i38

# ps -fe | grep dhc
root      3933     1  0 11:02 ?        00:00:00 /sbin/dhclient -d -sf
/usr/libexec/nm-dhcp-client.action -pf /var/run/dhclient-eth1.pid -lf
/var/run/dhclient-eth1.lease -cf /etc/dhclient-eth1.conf eth1
root      4354     1  0 11:03 ?        00:00:00 /sbin/dhclient -d -sf
/usr/libexec/nm-dhcp-client.action -pf /var/run/dhclient-eth0.pid -lf
/var/run/dhclient-eth0.lease -cf /etc/dhclient-eth0.conf eth0

# ls /etc/dhc*
/etc/dhclient.conf  /etc/dhcp6c.conf
Comment 1 Dan Williams 2008-04-10 13:39:51 EDT
You'll want to move those options to the interface specific config files
dhclient-eth0.conf, etc, not in dhclient.conf.

however, can you attach the output of /var/log/messages where NM shows what
options dhclient is returning so we can figure out if this is a dhclient problem
or an NM problem?  Thanks!
Comment 2 Orion Poplawski 2008-04-11 14:00:15 EDT
(In reply to comment #1)
> You'll want to move those options to the interface specific config files
> dhclient-eth0.conf, etc, not in dhclient.conf.
> 

This seems to reverse prior behaviour as indicated by bug #385211.  Also, it
makes things difficult from a sysadmin perspective when the names and number of
interfaces change from machine to machine, but I want the options to apply to
all interfaces.

> however, can you attach the output of /var/log/messages where NM shows what
> options dhclient is returning so we can figure out if this is a dhclient problem
> or an NM problem?  Thanks!

I suspect the duplication might be arising out of having both the wired and
wireless connection active at the same time - and the wireless bounces up and
down.  I can't reproduce the duplicate entries at the moment.

One problem I do see though - I connect to wireless with wired connected.  Then
unplug the wired connection.  nm-applet icon goes to the crossed out plug and
/etc/resolv.conf is emptied though the wireless connection is still active.

NM messages after pulling:
Apr 11 11:55:34 bona NetworkManager: <info>  Deactivating device eth0.
Apr 11 11:55:34 bona NetworkManager: <info>  eth0: canceled DHCP transaction,
dhclient pid 2220

Ah, then I plug back in and I get the duplicate entries in /etc/resolv.conf.  NM
messages

Apr 11 11:58:47 bona NetworkManager: <info>  Policy set (eth1) as default device
for routing and DNS.
Apr 11 11:58:47 bona NetworkManager: <info>  Activation (eth0) starting
connection 'Auto eth0'
Apr 11 11:58:47 bona NetworkManager: <info>  Activation (eth0) Stage 1 of 5
(Device Prepare) scheduled...
Apr 11 11:58:47 bona NetworkManager: <info>  Activation (eth0) Stage 1 of 5
(Device Prepare) started...
Apr 11 11:58:47 bona NetworkManager: <info>  Activation (eth0) Stage 2 of 5
(Device Configure) scheduled...
Apr 11 11:58:47 bona NetworkManager: <info>  Activation (eth0) Stage 1 of 5
(Device Prepare) complete.
Apr 11 11:58:47 bona NetworkManager: <info>  Activation (eth0) Stage 2 of 5
(Device Configure) starting...
Apr 11 11:58:47 bona NetworkManager: <info>  Activation (eth0) Stage 2 of 5
(Device Configure) successful.
Apr 11 11:58:47 bona NetworkManager: <info>  Activation (eth0) Stage 3 of 5
(IPConfigure Start) scheduled.
Apr 11 11:58:47 bona NetworkManager: <info>  Activation (eth0) Stage 2 of 5
(Device Configure) complete.
Apr 11 11:58:47 bona NetworkManager: <info>  Activation (eth0) Stage 3 of 5
(IPConfigure Start) started...
Apr 11 11:58:47 bona NetworkManager: <info>  Activation (eth0) Beginning DHCP
transaction.
Apr 11 11:58:47 bona NetworkManager: <info>  dhclient started with pid 4484
Apr 11 11:58:47 bona NetworkManager: <info>  Activation (eth0) Stage 3 of 5
(IPConfigure Start) complete.
Apr 11 11:58:47 bona NetworkManagerDispatcher: stopping ypbind
Apr 11 11:58:47 bona NetworkManager: <info>  DHCP: device eth0 state changed
normal exit -> preinit
Apr 11 11:58:47 bona NetworkManagerDispatcher: stopping autofs
Apr 11 11:58:50 bona NetworkManagerDispatcher: stopping ntpd
Apr 11 11:58:51 bona NetworkManager: <info>  DHCP: device eth0 state changed
preinit -> bound
Apr 11 11:58:51 bona NetworkManager: <info>  Activation (eth0) Stage 4 of 5
(IPConfigure Get) scheduled...
Apr 11 11:58:51 bona NetworkManager: <info>  Activation (eth0) Stage 4 of 5
(IPConfigure Get) started...
Apr 11 11:58:51 bona NetworkManager: <info>    address 192.168.0.113
Apr 11 11:58:51 bona NetworkManager: <info>    netmask 255.255.255.0
Apr 11 11:58:51 bona NetworkManager: <info>    broadcast 192.168.0.255
Apr 11 11:58:51 bona NetworkManager: <info>    gateway 192.168.0.1
Apr 11 11:58:51 bona NetworkManager: <info>    nameserver '192.168.0.8'
Apr 11 11:58:51 bona NetworkManager: <info>    nameserver '192.168.0.12'
Apr 11 11:58:51 bona NetworkManager: <info>    hostname 'bona'
Apr 11 11:58:51 bona NetworkManager: <info>    domain name 'cora.nwra.com'
Apr 11 11:58:51 bona NetworkManager: <info>  Activation (eth0) Stage 5 of 5
(IPConfigure Commit) scheduled...
Apr 11 11:58:51 bona NetworkManager: <info>  Activation (eth0) Stage 4 of 5
(IPConfigure Get) complete.
Apr 11 11:58:51 bona NetworkManager: <info>  Activation (eth0) Stage 5 of 5
(IPConfigure Commit) started...
Apr 11 11:58:52 bona NetworkManager: <info>  Policy set (eth1) as default device
for routing and DNS.
Apr 11 11:58:52 bona NetworkManager: <info>  Policy set (eth0) as default device
for routing and DNS.
Apr 11 11:58:52 bona NetworkManager: <info>  Activation (eth0) successful,
device activated.
Apr 11 11:58:52 bona NetworkManager: <info>  Activation (eth0) Stage 5 of 5
(IPConfigure Commit) complete.
Comment 3 Dan Williams 2008-04-28 00:52:19 EDT
Any chance you could pull down the latest koji:

http://koji.fedoraproject.org/koji/buildinfo?buildID=47429

and see if that fixes the multi-connection issues for you?  It should... Thanks!
Comment 4 Orion Poplawski 2008-04-28 17:04:19 EDT
Well, 3614 still brings up the wireless network in addition to the wired
network.  However, when I unplug, the applet icon immediately changes to a
wireless icon.  When I plug in the cable again I'm back to the plug icon but I
have duplicate nameserver/domain entries in /etc/resolv.conf again.  So, the
icons are correct, but that's about it it seems.
Comment 5 Bug Zapper 2008-05-14 05:15:42 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Gene Czarcinski 2008-05-15 11:38:59 EDT
OK, until NetworkManager can be changed to properly handling dynamic host name
update [that is, passing the DHCP_HOSTNAME= to dhcpd], I have come up with a
workaround that handles both wired and wireless connections.

There already is come code so that specifying 'send host-name "xxxx"; ' in a
/etc/dhclient-eth0.conf file will set the name "xxxx" when dhclient initializes
the interface.  You can either do this manually or use s-c-network.  This should
also be set by anaconda but is not ... anaconda only sets NM_CONTROLLED= rather
than NM_CONTROLLED=yes as well.

Now I have found that I can "fake it" for wireless connections.  I created a
/etc/dhclient-wlan0.con with 'send host-name "xxxx"; ' in it and it worked ...
dhcpd updated dns with the "xxxx" name.

Since interface connections may go up or down but a system name is usually
fixed, there should be some central place to specify the name ...
/etc/dhclient.conf ??
Comment 7 Gene Czarcinski 2008-05-15 12:02:39 EDT
Well, it does not work perfectly the way I wanted ... the names must be
different on wired and wireless.  bind (named) rejected making them the smae and
updating the ip.
Comment 8 Fedora Update System 2008-07-30 15:59:46 EDT
NetworkManager-0.7.0-0.11.svn3846.fc9, NetworkManager-vpnc-0.7.0-0.10.svn3846.fc9, NetworkManager-openvpn-0.7.0-15.svn3846.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager NetworkManager-vpnc NetworkManager-openvpn'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-6761
Comment 9 Fedora Update System 2008-08-11 22:29:37 EDT
NetworkManager-openvpn-0.7.0-15.svn3930.fc9,NetworkManager-vpnc-0.7.0-0.10.svn3928.fc9,NetworkManager-0.7.0-0.11.svn3930.fc9 has been submitted as an update for Fedora 9
Comment 10 Fedora Update System 2008-08-11 22:34:44 EDT
NetworkManager-openvpn-0.7.0-15.svn3930.fc8,NetworkManager-vpnc-0.7.0-0.10.svn3928.fc8,NetworkManager-0.7.0-0.11.svn3930.fc8 has been submitted as an update for Fedora 8
Comment 11 Fedora Update System 2008-08-29 10:56:09 EDT
NetworkManager-openvpn-0.7.0-15.svn4027.fc9,NetworkManager-vpnc-0.7.0-0.10.svn4024.fc9,NetworkManager-0.7.0-0.11.svn4022.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/NetworkManager-openvpn-0.7.0-15.svn4027.fc9,NetworkManager-vpnc-0.7.0-0.10.svn4024.fc9,NetworkManager-0.7.0-0.11.svn4022.fc9
Comment 12 Fedora Update System 2008-09-02 16:41:37 EDT
NetworkManager-0.7.0-0.11.svn4022.fc8,NetworkManager-openvpn-0.7.0-15.svn4027.fc8,NetworkManager-vpnc-0.7.0-0.10.svn4024.fc8,NetworkManager-pptp-0.7.0-0.10.svn4027.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/NetworkManager-0.7.0-0.11.svn4022.fc8,NetworkManager-openvpn-0.7.0-15.svn4027.fc8,NetworkManager-vpnc-0.7.0-0.10.svn4024.fc8,NetworkManager-pptp-0.7.0-0.10.svn4027.fc8
Comment 13 Fedora Update System 2008-09-10 02:36:33 EDT
NetworkManager-pptp-0.7.0-0.10.svn4027.fc9, NetworkManager-openvpn-0.7.0-15.svn4027.fc9, NetworkManager-vpnc-0.7.0-0.10.svn4024.fc9, NetworkManager-0.7.0-0.11.svn4022.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager-pptp NetworkManager-openvpn NetworkManager-vpnc NetworkManager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-7375
Comment 14 Fedora Update System 2008-09-10 02:54:14 EDT
NetworkManager-0.7.0-0.11.svn4022.fc8, NetworkManager-openvpn-0.7.0-15.svn4027.fc8, NetworkManager-vpnc-0.7.0-0.10.svn4024.fc8, NetworkManager-pptp-0.7.0-0.10.svn4027.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager NetworkManager-openvpn NetworkManager-vpnc NetworkManager-pptp'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-7484
Comment 15 Fedora Update System 2008-09-28 14:42:26 EDT
NetworkManager-0.7.0-0.11.svn4022.fc8, NetworkManager-openvpn-0.7.0-15.svn4027.fc8, NetworkManager-vpnc-0.7.0-0.10.svn4024.fc8, NetworkManager-pptp-0.7.0-0.10.svn4027.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2008-09-28 14:45:17 EDT
NetworkManager-pptp-0.7.0-0.10.svn4027.fc9, NetworkManager-openvpn-0.7.0-15.svn4027.fc9, NetworkManager-vpnc-0.7.0-0.10.svn4024.fc9, NetworkManager-0.7.0-0.11.svn4022.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.