Bug 441892 - mugshot crashes firefox
Summary: mugshot crashes firefox
Status: CLOSED DUPLICATE of bug 441643
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox   
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
high
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL: http://mugshot.org/visit?post=R43l8bh...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-04-10 17:35 UTC by Axel Thimm
Modified: 2008-04-10 17:53 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-10 17:53:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Axel Thimm 2008-04-10 17:35:16 UTC
Description of problem:

The URL http://mugshot.org/visit?post=R43l8bh5QClq8M crashes firefox with

** (firefox:4086): DEBUG: Connected to session bus
** (firefox:4086): DEBUG: unique name of client: :1.11
** (firefox:4086): DEBUG: adding rule
type='signal',sender=':1.11',path='/com/dumbhippo/listener',interface='com.dumbhippo.Listener',member='Connected'
** (firefox:4086): DEBUG: adding rule
type='signal',sender=':1.11',path='/com/dumbhippo/listener',interface='com.dumbhippo.Listener',member='Disconnected'
/usr/lib64/firefox-3.0b5/run-mozilla.sh: line 131:  4086 Segmentation fault    
 "$prog" ${1+"$@"}


Version-Release number of selected component (if applicable):
firefox-3.0-0.53.beta5.fc9.x86_64

How reproducible:
always

Steps to Reproduce:
1.firefox http://mugshot.org/visit?post=R43l8bh5QClq8M
2.
3.
  
Actual results:
See above

Expected results:
no crash

Additional info:
Maybe related to bug #441890?

Comment 1 Christopher Aillon 2008-04-10 17:51:30 UTC
Out of curiosity, can you test to see whether this is fixed using the F-10
xulrunner/firefox package set (from koji)?  If so, we can investigate to see
which of the various patches have fixed it and attempt to pull it in.  If not,
further investigation is needed.

Comment 2 Christopher Aillon 2008-04-10 17:52:40 UTC
Or, is this caused by the extension itself?  In which case, this probably should
be assigned to the mugshot component...

Comment 3 Owen Taylor 2008-04-10 17:53:07 UTC

*** This bug has been marked as a duplicate of 441643 ***


Note You need to log in before you can comment on or make changes to this bug.